低危 apt整数溢出漏洞

CVE编号

CVE-2020-27350

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-12-10
漏洞描述
APT在解析.deb包(又称GHSL-2020-168GHSL-2020-169)时,在apt-pkg/contrib/extracttar.cc、apt-pkg/deb/debfile.cc和apt-pkg/contrib/arfile.cc文件中有几个整数溢出和下溢。以下产品及版本受到影响:apt 1.2.32ubuntu0 versions prior to 1.2.32ubuntu0.2; 1.6.12ubuntu0 versions prior to 1.6.12ubuntu0.2; 2.0.2ubuntu0 versions prior to 2.0.2ubuntu0.2; 2.1.10ubuntu0 versions prior to 2.1.10ubuntu0.1

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://ubuntu.com/security/CVE-2020-27350


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian advanced_package_tool * Up to
(excluding)
1.8.2.2
运行在以下环境
应用 debian advanced_package_tool * From
(including)
1.2.32ubuntu0
Up to
(excluding)
1.2.32ubuntu0.2
运行在以下环境
应用 debian advanced_package_tool * From
(including)
1.6.12ubuntu0
Up to
(excluding)
1.6.12ubuntu0.2
运行在以下环境
应用 debian advanced_package_tool * From
(including)
2.0.2ubuntu0
Up to
(excluding)
2.0.2ubuntu0.2
运行在以下环境
应用 debian advanced_package_tool * From
(including)
2.1.10ubuntu0
Up to
(excluding)
2.1.10ubuntu0.2
运行在以下环境
系统 debian_10 apt * Up to
(excluding)
1.8.2.2
运行在以下环境
系统 debian_11 apt * Up to
(excluding)
2.1.12
运行在以下环境
系统 debian_9 apt * Up to
(excluding)
1.4.11
运行在以下环境
系统 ubuntu_14.04 apt * Up to
(excluding)
1.0.1ubuntu2.24+esm3
运行在以下环境
系统 ubuntu_16.04 apt * Up to
(excluding)
1.2.32ubuntu0.2
运行在以下环境
系统 ubuntu_18.04 apt * Up to
(excluding)
1.6.12ubuntu0.2
运行在以下环境
系统 ubuntu_20.04 apt * Up to
(excluding)
2.0.2ubuntu0.2
运行在以下环境
系统 ubuntu_21.04 apt * Up to
(excluding)
2.1.13
运行在以下环境
系统 unionos_20 apt * Up to
(excluding)
1.8.2.4-1+eagle
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    管控权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况