低危 Python-apt拒绝服务漏洞

CVE编号

CVE-2020-27351

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-12-10
漏洞描述
Python-apt是Python-apt团队的一个可支持Apt软件包管理工具的Pypi代码库。 python-apt 存在安全漏洞,该漏洞源于python-apt错误地处理了资源。一种本地攻击者可能会使用此问题来导致python-apt消耗资源,导致拒绝服务。以下产品及版本受到影响:python-apt 1.1.0~beta1 versions prior to 1.1.0~beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://ubuntu.com/security/CVE-2020-27351


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian advanced_package_tool * Up to
(excluding)
1.8.4.2
运行在以下环境
应用 debian advanced_package_tool * From
(including)
1.1.0\~beta1
Up to
(excluding)
1.1.0\~beta1ubuntu0.16.04.10
运行在以下环境
应用 debian advanced_package_tool * From
(including)
1.6.5ubuntu0
Up to
(excluding)
1.6.5ubuntu0.4
运行在以下环境
应用 debian advanced_package_tool * From
(including)
2.0.0ubuntu0
Up to
(excluding)
2.0.0ubuntu0.20.04.2
运行在以下环境
应用 debian advanced_package_tool * From
(including)
2.1.3ubuntu1
Up to
(excluding)
2.1.30ubuntu1.1
运行在以下环境
系统 debian_10 python-apt * Up to
(excluding)
1.8.4.2
运行在以下环境
系统 debian_11 python-apt * Up to
(including)
2.1.6
运行在以下环境
系统 debian_9 python-apt * Up to
(excluding)
1.4.2
运行在以下环境
系统 ubuntu_14.04 python-apt * Up to
(excluding)
0.9.3.5ubuntu3+esm4
运行在以下环境
系统 ubuntu_16.04 python-apt * Up to
(excluding)
1.1.0~beta1ubuntu0.16.04.10
运行在以下环境
系统 ubuntu_16.04.7_lts python-apt * Up to
(excluding)
1.1.0~beta1ubuntu0.16.04.10
运行在以下环境
系统 ubuntu_18.04 python-apt * Up to
(excluding)
1.6.5ubuntu0.4
运行在以下环境
系统 ubuntu_18.04.5_lts python-apt * Up to
(excluding)
1.6.5ubuntu0.4
运行在以下环境
系统 ubuntu_20.04 python-apt * Up to
(excluding)
2.0.0ubuntu0.20.04.2
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    -
CWE-ID 漏洞类型
CWE-772 对已超过有效生命周期的资源丧失索引
阿里云安全产品覆盖情况