低危 Open Stack Manila证书保护不足漏洞

CVE编号

CVE-2020-27781

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-12-19
漏洞描述
OpenStack是美国国家航空航天局(National Aeronautics and Space Administration)和美国Rackspace公司合作研发的一个云平台管理项目。 OpenStack Manila的Native CephFS使用者可以操纵和窃取用户凭证,从而导致潜在的权限提升。 Open Stack Manila用户可以向任意cephx用户(包括现有用户)请求访问共享。通过接口驱动程序检索访问密钥。然后,请求OpenStack项目的所有用户都可以查看访问密钥。这使攻击者可以将用户有权访问的任何资源作为目标。甚至可以对“管理员”用户执行此操作,从而损害了ceph管理员。此漏洞影响16.2.0之前的Ceph版本。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ceph * Up to
(excluding)
16.2.0
运行在以下环境
应用 redhat ceph_storage 2.0 -
运行在以下环境
应用 redhat ceph_storage 3.0 -
运行在以下环境
应用 redhat ceph_storage 4.0 -
运行在以下环境
应用 redhat openshift_container_platform 4.0 -
运行在以下环境
应用 redhat openstack_platform 13.0 -
运行在以下环境
系统 alpine_3.11 ceph * Up to
(excluding)
14.2.19-r0
运行在以下环境
系统 alpine_3.12 ceph * Up to
(excluding)
14.2.19-r0
运行在以下环境
系统 alpine_3.13 ceph * Up to
(excluding)
15.2.8-r0
运行在以下环境
系统 alpine_3.14 ceph * Up to
(excluding)
15.2.8-r0
运行在以下环境
系统 alpine_3.15 ceph * Up to
(excluding)
15.2.8-r0
运行在以下环境
系统 alpine_3.16 ceph * Up to
(excluding)
15.2.8-r0
运行在以下环境
系统 alpine_edge ceph * Up to
(excluding)
15.2.8-r0
运行在以下环境
系统 centos_8 ceph * Up to
(excluding)
14.2.11-95.el8cp
运行在以下环境
系统 debian_10 ceph * Up to
(including)
12.2.11+dfsg1-2.1
运行在以下环境
系统 debian_11 ceph * Up to
(including)
14.2.15-3
运行在以下环境
系统 debian_9 ceph * Up to
(including)
10.2.11-2
运行在以下环境
系统 debian_sid ceph * Up to
(including)
14.2.15-3
运行在以下环境
系统 fedora_33 ceph * Up to
(excluding)
15.2.8-1.fc33
运行在以下环境
系统 opensuse_Leap_15.1 ceph * Up to
(excluding)
14.2.16.402
运行在以下环境
系统 opensuse_Leap_15.2 ceph * Up to
(excluding)
15.2.8.80
运行在以下环境
系统 redhat_8 ceph * Up to
(excluding)
14.2.11-95.el8cp
运行在以下环境
系统 ubuntu_18.04 ceph * Up to
(excluding)
12.2.13-0ubuntu0.18.04.10
运行在以下环境
系统 ubuntu_18.04.5_lts ceph * Up to
(excluding)
12.2.13-0ubuntu0.18.04.10
运行在以下环境
系统 ubuntu_20.04 ceph * Up to
(excluding)
15.2.12-0ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_21.04 ceph * Up to
(excluding)
16.2.0-0ubuntu1
运行在以下环境
系统 ubuntu_21.10 ceph * Up to
(excluding)
16.2.0-0ubuntu1
运行在以下环境
系统 ubuntu_22.04 ceph * Up to
(excluding)
16.2.0-0ubuntu1
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-522 不充分的凭证保护机制
阿里云安全产品覆盖情况