低危 asterisk open_source 不恰当的资源关闭或释放

CVE编号

CVE-2020-28327

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-11-07
漏洞描述
A res_pjsip_session crash was discovered in Asterisk Open Source 13.x before 13.37.1, 16.x before 16.14.1, 17.x before 17.8.1, and 18.x before 18.0.1. and Certified Asterisk before 16.8-cert5. Upon receiving a new SIP Invite, Asterisk did not return the created dialog locked or referenced. This caused a gap between the creation of the dialog object, and its next use by the thread that created it. Depending on some off-nominal circumstances and timing, it was possible for another thread to free said dialog in this gap. Asterisk could then crash when the dialog object, or any of its dependent objects, were dereferenced or accessed next by the initial-creation thread. Note, however, that this crash can only occur when using a connection-oriented protocol (e.g., TCP or TLS, but not UDP) for SIP transport. Also, the remote client must be authenticated, or Asterisk must be configured for anonymous calling.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 asterisk open_source * From
(including)
13.0.0
Up to
(excluding)
13.37.1
运行在以下环境
应用 asterisk open_source * From
(including)
16.0.0
Up to
(excluding)
16.14.1
运行在以下环境
应用 asterisk open_source * From
(including)
17.0.0
Up to
(excluding)
17.8.1
运行在以下环境
应用 asterisk open_source * From
(including)
18.0.0
Up to
(excluding)
18.0.1
运行在以下环境
应用 digium certified_asterisk 16.8 -
运行在以下环境
系统 alpine_3.12 asterisk * Up to
(excluding)
16.14.1-r0
运行在以下环境
系统 alpine_3.13 asterisk * Up to
(excluding)
18.0.1-r0
运行在以下环境
系统 alpine_3.14 asterisk * Up to
(excluding)
18.0.1-r0
运行在以下环境
系统 alpine_3.15 asterisk * Up to
(excluding)
18.0.1-r0
运行在以下环境
系统 alpine_3.16 asterisk * Up to
(excluding)
18.0.1-r0
运行在以下环境
系统 alpine_edge asterisk * Up to
(excluding)
18.0.1-r0
运行在以下环境
系统 debian_10 asterisk * Up to
(including)
16.2.1~dfsg-1+deb10u2
运行在以下环境
系统 debian_9 asterisk * Up to
(including)
13.14.1~dfsg-2+deb9u4
运行在以下环境
系统 debian_sid asterisk * Up to
(including)
16.12.0~dfsg-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-404 不恰当的资源关闭或释放
阿里云安全产品覆盖情况