低危 go代码注入漏洞

CVE编号

CVE-2020-28366

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-11-19
漏洞描述
Google Go Cmd/go是美国谷歌(Google)公司的一个为Go语言提供命令支持的代码库。 go 1.15.5,1之前版本存在安全漏洞,该漏洞源于当使用cgo时,go命令可能在构建时执行任意代码。当在恶意包上运行go get或构建不受信任代码的任何其他命令时,可能会出现这种情况。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://www.vuxml.org/freebsd/db4b2f27-252a-11eb-865c-00155d646400.html


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * Up to
(excluding)
1.14.12
运行在以下环境
应用 golang go * From
(including)
1.15
Up to
(excluding)
1.15.4
运行在以下环境
系统 alpine_3.13 go * Up to
(excluding)
1.15.5-r0
运行在以下环境
系统 alpine_3.14 go * Up to
(excluding)
1.15.5-r0
运行在以下环境
系统 alpine_3.15 go * Up to
(excluding)
1.15.5-r0
运行在以下环境
系统 alpine_3.16 go * Up to
(excluding)
1.15.5-r0
运行在以下环境
系统 alpine_edge go * Up to
(excluding)
1.15.5-r0
运行在以下环境
系统 amazon_2 go * Up to
(excluding)
1.15.5-1.amzn2.0.2
运行在以下环境
系统 amazon_AMI go * Up to
(excluding)
1.15.5-1.65.amzn1
运行在以下环境
系统 centos_8 go * Up to
(excluding)
1.4.1-1.module+el8.3.0+7840+63dfb1ed
运行在以下环境
系统 debian_10 go * Up to
(including)
1.11.6-1+deb10u4
运行在以下环境
系统 debian_11 go * Up to
(including)
1.15.2-1
运行在以下环境
系统 debian_9 go * Up to
(including)
1.7.4-2+deb9u1
运行在以下环境
系统 fedora_32 go * Up to
(excluding)
1.14.13-1.fc32
运行在以下环境
系统 fedora_33 go * Up to
(excluding)
1.15.5-1.fc33
运行在以下环境
系统 fedora_EPEL_6 go * Up to
(excluding)
1.15.5-1.el6
运行在以下环境
系统 fedora_EPEL_7 go * Up to
(excluding)
1.15.5-1.el7
运行在以下环境
系统 opensuse_Leap_15.1 go * Up to
(excluding)
1.14.12-lp151.22.1
运行在以下环境
系统 opensuse_Leap_15.2 go * Up to
(excluding)
1.14.12-lp152.2.12.1
运行在以下环境
系统 oracle_8 go * Up to
(excluding)
1.14.12-1.module+el8.3.0+7887+1b2c3dab
运行在以下环境
系统 redhat_8 go * Up to
(excluding)
1.4.1-1.module+el8.3.0+7840+63dfb1ed
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况