低危 Google Go 输入验证错误漏洞

CVE编号

CVE-2020-28851

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-01-02
漏洞描述
Google Go是美国谷歌(Google)公司的一款静态强类型、编译型、并发型,并具有垃圾回收功能的编程语言。

Go 1.15.4版本存在安全漏洞,该漏洞源于在language.ParseAcceptLanguage BCP 47 tag x/text中会出现“index out of range”。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/golang/go/issues/42535
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go 1.15.4 -
运行在以下环境
系统 debian_10 golang-x-text * Up to
(including)
0.3.0-2
运行在以下环境
系统 debian_11 golang-x-text * Up to
(including)
0.3.4-1
运行在以下环境
系统 debian_9 golang-x-text * Up to
(including)
0.0~git20161013.0.c745997-2
运行在以下环境
系统 debian_sid golang-x-text * Up to
(including)
0.3.4-1
运行在以下环境
系统 fedora_EPEL_7 golang-x-text * Up to
(excluding)
1.15.14-1.el7
运行在以下环境
系统 ubuntu_21.10 golang-x-text * Up to
(excluding)
0.3.6-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-129 对数组索引的验证不恰当
阿里云安全产品覆盖情况