低危 Mutt和NeoMutt加密漏洞

CVE编号

CVE-2020-28896

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-11-24
漏洞描述
Mutt是Michael Elkins个人开发者的一款用于类Unix系统下且基于文本的邮件客户端。NeoMutt是一款命令行邮件阅读器。 Mutt 2.0.2 之前版本和 NeoMutt 2020-11-20之前版本存在安全漏洞,该漏洞源于不能确保处理$ssl force tls,连接未正确关闭,代码可能继续尝试进行身份验证。这可能导致身份验证凭据暴露在未加密的连接上,或暴露在中间的机器上。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://github.com/neomutt/neomutt/releases/tag/20201120


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mutt mutt * Up to
(excluding)
2.0.2
运行在以下环境
应用 neomutt neomutt * Up to
(excluding)
2020-11-20
运行在以下环境
系统 alpine_3.13 mutt * Up to
(excluding)
2.0.2-r0
运行在以下环境
系统 alpine_3.14 mutt * Up to
(excluding)
2.0.2-r0
运行在以下环境
系统 alpine_3.15 mutt * Up to
(excluding)
2.0.2-r0
运行在以下环境
系统 alpine_3.16 mutt * Up to
(excluding)
2.0.2-r0
运行在以下环境
系统 alpine_edge mutt * Up to
(excluding)
2.0.2-r0
运行在以下环境
系统 centos_8 mutt * Up to
(excluding)
2.0.7-1.el8
运行在以下环境
系统 debian_10 mutt * Up to
(excluding)
1.10.1-2.1+deb10u4
运行在以下环境
系统 debian_9 mutt * Up to
(excluding)
1.7.2-1+deb9u4
运行在以下环境
系统 opensuse_Leap_15.1 mutt * Up to
(excluding)
1.10.1-lp151.2.6.1
运行在以下环境
系统 opensuse_Leap_15.2 mutt * Up to
(excluding)
1.10.1-lp152.3.6.1
运行在以下环境
系统 redhat_8 mutt * Up to
(excluding)
2.0.7-1.el8
运行在以下环境
系统 suse_12_SP5 mutt * Up to
(excluding)
1.10.1-55.18.1
运行在以下环境
系统 ubuntu_16.04 mutt * Up to
(excluding)
1.5.24-1ubuntu0.5
运行在以下环境
系统 ubuntu_16.04.7_lts mutt * Up to
(excluding)
1.5.24-1ubuntu0.5
运行在以下环境
系统 ubuntu_18.04 mutt * Up to
(excluding)
1.9.4-3ubuntu0.4
运行在以下环境
系统 ubuntu_18.04.5_lts mutt * Up to
(excluding)
1.9.4-3ubuntu0.4
运行在以下环境
系统 ubuntu_20.04 mutt * Up to
(excluding)
1.13.2-1ubuntu0.3
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
CWE-522 不充分的凭证保护机制
CWE-755 对异常条件的处理不恰当
阿里云安全产品覆盖情况