中危 SQLite 缓冲区错误漏洞(CVE-2020-35527)

CVE编号

CVE-2020-35527

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-09-02
漏洞描述
SQLite是一款轻型的数据库,是遵守ACID的关系型数据库管理系统。

SQLite 3.31.1版本存在安全漏洞,该漏洞源于对于具有嵌套 FROM 子句的视图,ALTER TABLE 存在越界访问问题。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.sqlite.org/src/info/c431b3fd8fd0f6a6
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 sqlite sqlite 3.31.1 -
运行在以下环境
系统 centos_8 sqlite3 * Up to
(excluding)
3.26.0-16.el8_6
运行在以下环境
系统 debian_10 sqlite3 * Up to
(excluding)
3.27.2-3+deb10u2
运行在以下环境
系统 redhat_8 sqlite3 * Up to
(excluding)
3.26.0-16.el8_6
运行在以下环境
系统 ubuntu_20.04 sqlite3 * Up to
(excluding)
3.31.1-4ubuntu0.4
阿里云评分
6.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况