低危 apt 至 2.1.1 ar/tar deb File 输入验证漏洞

CVE编号

CVE-2020-3810

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-16
漏洞描述
apt是Debian计划合作组织的一个命令行软件包管理器,它提供搜索、管理和查询软件包信息功能。
apt 2.1.2之前版本中的ar/tar实现存在输入验证错误漏洞。该漏洞源于网络系统或产品未对输入的数据进行正确的验证。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://lists.debian.org/debian-lts-announce/2020/05/msg00013.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian apt * Up to
(excluding)
2.1.2
运行在以下环境
系统 debian_10 apt * Up to
(excluding)
1.8.2.1
运行在以下环境
系统 debian_8 apt * Up to
(excluding)
1.0.9.8.4
运行在以下环境
系统 debian_9 apt * Up to
(excluding)
1.4.10
运行在以下环境
系统 fedora_32 apt * Up to
(excluding)
2.1.7-1.fc32
运行在以下环境
系统 ubuntu_14.04 apt * Up to
(excluding)
1.0.1ubuntu2.24+esm1
运行在以下环境
系统 ubuntu_16.04 apt * Up to
(excluding)
1.2.32ubuntu0.1
运行在以下环境
系统 ubuntu_16.04.7_lts apt * Up to
(excluding)
1.2.32ubuntu0.1
运行在以下环境
系统 ubuntu_18.04 apt * Up to
(excluding)
1.6.12ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts apt * Up to
(excluding)
1.6.12ubuntu0.1
运行在以下环境
系统 ubuntu_20.04 apt * Up to
(excluding)
2.0.2ubuntu0.1
运行在以下环境
系统 unionos_20 apt * Up to
(excluding)
1.8.2.2-1+dde
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况