低危 AUTH块输入验证中的缓冲区溢出

CVE编号

CVE-2020-6831

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-27
漏洞描述
在WebRTC中解析和验证SCTP块时,可能会发生缓冲区溢出。这可能导致内存损坏和潜在的可利用崩溃。此漏洞影响Firefox ESR <68.8,Firefox <76和Thunderbird <68.8.0。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://www.mozilla.org/en-US/security/advisories/mfsa2020-16/
https://www.mozilla.org/en-US/security/advisories/mfsa2020-17/
https://www.mozilla.org/en-US/security/advisories/mfsa2020-18/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mozilla firefox * Up to
(excluding)
76.0
运行在以下环境
应用 mozilla firefox_esr * Up to
(excluding)
68.8.0
运行在以下环境
应用 mozilla thunderbird * Up to
(excluding)
68.8.0
运行在以下环境
系统 redhat_6 firefox * Up to
(excluding)
0:68.8.0-1.el6_10
运行在以下环境
系统 redhat_6 thunderbird * Up to
(excluding)
0:68.8.0-1.el6_10
运行在以下环境
系统 redhat_7 firefox * Up to
(excluding)
0:68.8.0-1.el7_8
运行在以下环境
系统 redhat_7 thunderbird * Up to
(excluding)
0:68.8.0-1.el7_8
运行在以下环境
系统 suse_12 MozillaFirefox * Up to
(excluding)
68.8.0-109.119
运行在以下环境
系统 ubuntu_16.04.7_lts chromium-browser * Up to
(excluding)
81.0.4044.138-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04_lts chromium-browser * Up to
(excluding)
81.0.4044.138-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts chromium-browser * Up to
(excluding)
81.0.4044.138-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04_lts chromium-browser * Up to
(excluding)
81.0.4044.138-0ubuntu0.18.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-120 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)
CWE-787 跨界内存写
阿里云安全产品覆盖情况