低危 与OpenSSL 1.0.2或更高版本一起使用时,在openfortivpn 1.11.0中发现了一个问题

CVE编号

CVE-2020-7041

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-28 07:15:00
漏洞描述
与OpenSSL 1.0.2或更高版本一起使用时,在openfortivpn 1.11.0中发现了一个问题。 tunnel.c错误地处理了证书验证,因为X509_check_host否定错误代码被解释为成功的返回值。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openfortivpn_project openfortivpn * Up to
(excluding)
1.12.0
运行在以下环境
应用 openssl openssl * Up to
(including)
1.0.2
2
运行在以下环境
应用 opensuse backports_sle 15.0 sp1 -
3
运行在以下环境
系统 opensuse_Leap_15.1 openfortivpn * Up to
(excluding)
1.12.0-lp151.2.5.1
4
运行在以下环境
系统 debian_10 openfortivpn * Up to
(excluding)
1.8.1-1
5
运行在以下环境
系统 fedora_EPEL_7 openfortivpn * Up to
(excluding)
1.12.0-1.el7
6
运行在以下环境
系统 fedora_EPEL_8 openfortivpn * Up to
(excluding)
1.12.0-1.el8
7
运行在以下环境
系统 fedora_30 openfortivpn * Up to
(excluding)
1.12.0-1.fc30
8
运行在以下环境
系统 fedora_31 openfortivpn * Up to
(excluding)
1.12.0-1.fc31
9
运行在以下环境
系统 fedora_32 openfortivpn * Up to
(excluding)
1.12.0-1.fc32
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况