中危 AngularJS 跨站脚本漏洞

CVE编号

CVE-2020-7676

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-06-09
漏洞描述
AngularJS是一款基于TypeScript的开源Web应用程序框架。 angular.js 1.8.0之前版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/angular/angular.js/pull/17028/commits/05cf60677b0cdac47ce6b860cbb7b41957a2cbba
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 angularjs angular.js * Up to
(excluding)
1.8.0
运行在以下环境
系统 debian_10 angular.js * Up to
(including)
1.5.10-1
运行在以下环境
系统 debian_9 angular.js * Up to
(including)
1.5.10-1
阿里云评分
4.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况