低危 Puppet Enterprise 6.13.0 puppet.conf 证书验证漏洞

CVE编号

CVE-2020-7942

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-20
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Agent是一个Puppet代理端程序。
Puppet中存在信任管理问题漏洞,该漏洞源于不正确的证书验证。远程攻击者可利用该漏洞获取敏感信息。Puppet 6.13.0之前的6.x版本,Puppet 5.5.19之前的5.5.x版本;Puppet Agent 6.13.0之前的6.x版本,Puppet Agent 5.5.19之前的5.5.x版本。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/CVE-2020-7942/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * From
(including)
6.0.0
Up to
(excluding)
6.13.0
运行在以下环境
应用 puppet puppet_agent * From
(including)
6.0.0
Up to
(excluding)
6.13.0
运行在以下环境
系统 debian_10 puppet * Up to
(including)
5.5.10-4
运行在以下环境
系统 debian_11 puppet * Up to
(including)
5.5.22-2
运行在以下环境
系统 debian_12 puppet * Up to
(including)
5.5.22-4
运行在以下环境
系统 debian_9 puppet * Up to
(including)
4.8.2-5
运行在以下环境
系统 debian_sid puppet * Up to
(including)
5.5.22-4
运行在以下环境
系统 suse_12 puppet * Up to
(excluding)
3.8.5-15.12
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况