低危 Puppet和PuppetDB 信息泄露漏洞

CVE编号

CVE-2020-7943

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-03-12
漏洞描述
Puppet和Puppet Server都是美国Puppet(Puppet)实验室的产品。Puppet是一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是Puppet的企业版。PuppetDB是Puppet的下一代开源存储服务,它可用于管理所有平台生成的数据存储和检索。Puppet Server是一款用于将配置从主服务器推送到其他服务器的软件。
Puppet Enterprise、Puppet Server和PuppetDB中存在信息泄露漏洞。远程攻击者可利用该漏洞获取敏感信息。以下产品及版本受到影响:Puppet Enterprise 2018.1.13之前2018.1.x版本,2019.4.0之前版本;Puppet Server 6.9.1之前版本,5.3.12之前版本;PuppetDB 6.9.1之前版本,5.2.13之前版本。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/CVE-2020-7943/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * From
(including)
2018.1.0
Up to
(excluding)
2018.1.13
运行在以下环境
应用 puppet puppet * From
(including)
2019.0
Up to
(excluding)
2019.4.0
运行在以下环境
应用 puppet puppetdb * Up to
(excluding)
5.2.13
运行在以下环境
应用 puppet puppetdb * From
(including)
6.0.0
Up to
(excluding)
6.9.1
运行在以下环境
应用 puppet puppet_server * Up to
(excluding)
5.3.12
运行在以下环境
应用 puppet puppet_server * From
(including)
6.0.0
Up to
(excluding)
6.9.1
运行在以下环境
系统 debian_10 puppet * Up to
(including)
6.2.0-3
运行在以下环境
系统 debian_11 puppet * Up to
(including)
5.5.19-1
运行在以下环境
系统 debian_9 puppet * Up to
(including)
4.8.2-5
运行在以下环境
系统 debian_sid puppet * Up to
(including)
6.2.0-5
运行在以下环境
系统 unionos_20 puppet * Up to
(excluding)
5.5.10-4
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
NVD-CWE-noinfo
阿里云安全产品覆盖情况