中危 Joyent Node.js 信任管理问题漏洞

CVE编号

CVE-2020-8172

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2020-06-09
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Joyent Node.js是美国Joyent公司的一套建立在Google V8 JavaScript引擎之上的网络应用平台。该平台主要用于构建高度可伸缩的应用程序,以及编写能够处理数万条且同时连接到一个物理机的连接代码。
Joyent Node.js 12.18.0之前版本和14.4.0之前版本中存在信任管理问题漏洞。攻击者可利用该漏洞绕过主机证书验证。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://nodejs.org/en/blog/vulnerability/june-2020-security-releases/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nodejs node.js * From
(including)
12.0.0
Up to
(excluding)
12.18.0
运行在以下环境
应用 nodejs node.js * From
(including)
14.0.0
Up to
(excluding)
14.4.0
运行在以下环境
系统 alpine_3.11 nodejs * Up to
(excluding)
12.20.1-r0
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.18.3-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
12.18.0-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
12.18.0-r0
运行在以下环境
系统 alpine_3.15 nodejs * Up to
(excluding)
12.18.0-r0
运行在以下环境
系统 alpine_3.16 nodejs * Up to
(excluding)
14.4.0-r0
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
12.18.0-r0
运行在以下环境
系统 centos_8 nodejs * Up to
(excluding)
12.18.2-1.module+el8.2.0+7233+61d664c1
运行在以下环境
系统 oracle_8 nodejs * Up to
(excluding)
12.18.2-1.module+el8.2.0+7636+541a18d0
运行在以下环境
系统 redhat_8 nodejs * Up to
(excluding)
12.18.2-1.module+el8.2.0+7233+61d664c1
运行在以下环境
系统 suse_12 nodejs12 * Up to
(excluding)
12.18.0-1.14
阿里云评分
4.3
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况