低危 node core 缓冲区安全漏洞

CVE编号

CVE-2020-8201

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-09-19
漏洞描述
nodejs是是一个基于ChromeV8引擎的JavaScript运行环境通过对Chromev8引擎进行了封装以及使用事件驱动和非阻塞IO的应用让Javascript开发高性能的后台应用成为了可能。 Node Core 存在缓冲区安全漏洞,该漏洞源于CR-to-Hyphen,攻击者可利用该漏洞绕过限制获取敏感信息。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://nodejs.org/en/blog/vulnerability/september-2020-security-releases/#http-request-smuggling-due-to-cr-to-hyphen-conversion-high-cve-2020-8201


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nodejs node.js * From
(including)
12.0.0
Up to
(excluding)
12.18.4
运行在以下环境
应用 nodejs node.js * From
(including)
14.0.0
Up to
(excluding)
14.11.0
运行在以下环境
系统 alpine_3.11 libuv * Up to
(excluding)
12.20.1-r0
运行在以下环境
系统 alpine_3.12 libuv * Up to
(excluding)
12.18.4-r0
运行在以下环境
系统 alpine_3.13 libuv * Up to
(excluding)
14.11.0-r0
运行在以下环境
系统 alpine_3.14 libuv * Up to
(excluding)
12.18.4-r0
运行在以下环境
系统 alpine_3.15 libuv * Up to
(excluding)
12.18.4-r0
运行在以下环境
系统 alpine_3.16 libuv * Up to
(excluding)
12.18.4-r0
运行在以下环境
系统 alpine_edge libuv * Up to
(excluding)
14.11.0-r0
运行在以下环境
系统 amazon_2 libuv * Up to
(excluding)
1.39.0-1.amzn2
运行在以下环境
系统 centos_8 libuv * Up to
(excluding)
12.18.4-2.module+el8.2.0+8361+192e434e
运行在以下环境
系统 fedora_31 libuv * Up to
(excluding)
12.19.0-1.fc31
运行在以下环境
系统 fedora_32_Modular libuv * Up to
(excluding)
14-3220201203015508.43bbeeef
运行在以下环境
系统 fedora_33 libuv * Up to
(excluding)
14.15.1-1.fc33
运行在以下环境
系统 fedora_33_Modular libuv * Up to
(excluding)
14-3320201203015508.601d93de
运行在以下环境
系统 opensuse_Leap_15.2 libuv * Up to
(excluding)
12.18.4-lp152.3.6.1
运行在以下环境
系统 oracle_8 libuv * Up to
(excluding)
6.14.6-1.12.18.4.2.module+el8.2.0+7806+0b44ae23
运行在以下环境
系统 redhat_8 libuv * Up to
(excluding)
12.18.4-2.module+el8.2.0+8361+192e434e
运行在以下环境
系统 unionos_20 libuv * Up to
(excluding)
0
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-444 HTTP请求的解释不一致性(HTTP请求私运)
阿里云安全产品覆盖情况