低危 Node Core 安全漏洞

CVE编号

CVE-2020-8265

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-01-07
漏洞描述
Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 are vulnerable to a use-after-free bug in its TLS implementation. When writing to a TLS enabled socket, node::StreamBase::Write calls node::TLSWrap::DoWrite with a freshly allocated WriteWrap object as first argument. If the DoWrite method does not return an error, this object is passed back to the caller as part of a StreamWriteResult structure. This may be exploited to corrupt memory leading to a Denial of Service or potentially other exploits.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nodejs node.js * From
(including)
10.0.0
Up to
(excluding)
10.23.1
运行在以下环境
应用 nodejs node.js * From
(including)
12.0.0
Up to
(excluding)
12.20.1
运行在以下环境
应用 nodejs node.js * From
(including)
14.0.0
Up to
(excluding)
14.15.4
运行在以下环境
应用 nodejs node.js * From
(including)
15.0.0
Up to
(excluding)
15.5.1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 nodejs * Up to
(excluding)
14.15.4-2.1.al8
运行在以下环境
系统 alpine_3.11 nodejs * Up to
(excluding)
12.20.1-r0
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.20.1-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
14.15.4-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
14.15.4-r0
运行在以下环境
系统 alpine_3.15 nodejs * Up to
(excluding)
14.15.4-r0
运行在以下环境
系统 alpine_3.16 nodejs * Up to
(excluding)
15.5.1-r0
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
14.15.4-r0
运行在以下环境
系统 centos_8 nodejs * Up to
(excluding)
1.18.3-1.module+el8+2632+6c5111ed
运行在以下环境
系统 debian debian_linux 10.0 -
运行在以下环境
系统 debian_10 nodejs * Up to
(excluding)
10.23.1~dfsg-1~deb10u1
运行在以下环境
系统 debian_11 nodejs * Up to
(including)
12.19.0~dfsg-1
运行在以下环境
系统 debian_9 nodejs * Up to
(including)
4.8.2~dfsg-1
运行在以下环境
系统 debian_sid nodejs * Up to
(including)
12.19.0~dfsg-1
运行在以下环境
系统 fedoraproject fedora 33 -
运行在以下环境
系统 fedora_32 nodejs * Up to
(excluding)
12.20.1-1.fc32
运行在以下环境
系统 fedora_32_Modular nodejs * Up to
(excluding)
12-3220210105181808.43bbeeef
运行在以下环境
系统 fedora_33 nodejs * Up to
(excluding)
14.15.4-1.fc33
运行在以下环境
系统 fedora_33_Modular nodejs * Up to
(excluding)
12-3320210105181808.601d93de
运行在以下环境
系统 opensuse_Leap_15.1 nodejs * Up to
(excluding)
10.23.1-lp151.2.15.1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
14.15.4-lp152.5.1
运行在以下环境
系统 oracle linux_8 nodejs * Up to
(excluding)
10.23.1-1.module+el8.3.0+9642+87902f83
运行在以下环境
系统 oracle_8 nodejs * Up to
(excluding)
10.23.1-1.module+el8.3.0+9642+87902f83
运行在以下环境
系统 redhat_8 nodejs * Up to
(excluding)
1.18.3-1.module+el8+2632+6c5111ed
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况