低危 HAXX libcurl信任管理问题漏洞

CVE编号

CVE-2020-8286

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-12-15
漏洞描述
HAXX libcurl是瑞典Haxx(HAXX)公司的一款开源的客户端URL传输库。该产品支持FTP、SFTP、TFTP和HTTP等协议。 libcurl 存在信任管理问题漏洞,攻击者可利用该漏洞通过在libcurl上进行低级OCSP验证,充当中间人,在会话中读取或写入数据。

解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接: https://curl.se/docs/CVE-2020-8286.html


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx libcurl * From
(including)
7.41.0
Up to
(including)
7.73.0
运行在以下环境
系统 alpine_3.10 curl * Up to
(excluding)
7.66.0-r3
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.67.0-r3
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.69.1-r3
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.74.0-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.74.0-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.74.0-r0
运行在以下环境
系统 alpine_3.16 curl * Up to
(excluding)
7.74.0-r0
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.74.0-r0
运行在以下环境
系统 amazon_2 curl * Up to
(excluding)
7.76.1-4.amzn2.0.1
运行在以下环境
系统 centos_8 curl * Up to
(excluding)
7.61.1-18.el8
运行在以下环境
系统 debian_10 curl * Up to
(excluding)
7.64.0-4+deb10u2
运行在以下环境
系统 debian_11 curl * Up to
(including)
7.72.0-1
运行在以下环境
系统 debian_9 curl * Up to
(excluding)
7.52.1-5+deb9u13
运行在以下环境
系统 debian_sid curl * Up to
(including)
7.72.0-1
运行在以下环境
系统 fedora_32 curl * Up to
(excluding)
7.69.1-7.fc32
运行在以下环境
系统 fedora_33 curl * Up to
(excluding)
7.71.1-8.fc33
运行在以下环境
系统 opensuse_Leap_15.1 curl * Up to
(excluding)
7.60.0-lp151.5.18.1
运行在以下环境
系统 opensuse_Leap_15.2 curl * Up to
(excluding)
7.66.0-lp152.3.12.1
运行在以下环境
系统 oracle_8 curl * Up to
(excluding)
7.61.1-18.el8
运行在以下环境
系统 redhat_8 curl * Up to
(excluding)
7.61.1-18.el8
运行在以下环境
系统 suse_12_SP5 curl * Up to
(excluding)
7.60.0-11.9.1
运行在以下环境
系统 ubuntu_16.04 curl * Up to
(excluding)
7.47.0-1ubuntu2.18
运行在以下环境
系统 ubuntu_16.04.7_lts curl * Up to
(excluding)
7.47.0-1ubuntu2.18
运行在以下环境
系统 ubuntu_18.04 curl * Up to
(excluding)
7.58.0-2ubuntu3.12
运行在以下环境
系统 ubuntu_18.04.5_lts curl * Up to
(excluding)
7.58.0-2ubuntu3.12
运行在以下环境
系统 ubuntu_20.04 curl * Up to
(excluding)
7.68.0-1ubuntu2.4
运行在以下环境
系统 unionos_20 curl * Up to
(excluding)
7.64.1.4-4+security
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况