低危 isc bind 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)

CVE编号

CVE-2020-8625

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2021-02-18 12:15:00
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting valid values for the tkey-gssapi-keytab or tkey-gssapi-credentialconfiguration options. Although the default configuration is not vulnerable, GSS-TSIG is frequently used in networks where BIND is integrated with Samba, as well as in mixed-server environments that combine BIND servers with Active Directory domain controllers. The most likely outcome of a successful exploitation of the vulnerability is a crash of the named process. However, remote code execution, while unproven, is theoretically possible. Affects: BIND 9.5.0 -> 9.11.27, 9.12.0 -> 9.16.11, and versions BIND 9.11.3-S1 -> 9.11.27-S1 and 9.16.8-S1 -> 9.16.11-S1 of BIND Supported Preview Edition. Also release versions 9.17.0 -> 9.17.1 of the BIND 9.17 development branch
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 isc bind * From
(including)
9.5.0
Up to
(including)
9.11.27
运行在以下环境
应用 isc bind 9.11.3 s1 -
运行在以下环境
应用 isc bind 9.11.5 s3 -
运行在以下环境
应用 isc bind 9.11.5 s5 -
运行在以下环境
应用 isc bind 9.11.6 s1 -
运行在以下环境
应用 isc bind 9.11.7 s1 -
运行在以下环境
应用 isc bind 9.11.8 s1 -
运行在以下环境
应用 isc bind 9.11.21 s1 -
运行在以下环境
应用 isc bind 9.11.27 s1 -
运行在以下环境
应用 isc bind * From
(including)
9.12.0
Up to
(including)
9.16.11
运行在以下环境
应用 isc bind 9.16.8 s1 -
运行在以下环境
应用 isc bind 9.16.11 s1 -
运行在以下环境
应用 isc bind 9.17.0 -
运行在以下环境
应用 isc bind 9.17.1 -
2
运行在以下环境
系统 alpine_3.11 bind * Up to
(excluding)
9.16.11-r2
3
运行在以下环境
系统 alpine_3.10 bind * Up to
(excluding)
9.16.11-r2
4
运行在以下环境
系统 alpine_3.13 bind * Up to
(excluding)
9.16.11-r2
5
运行在以下环境
系统 alpine_3.12 bind * Up to
(excluding)
9.16.11-r2
6
运行在以下环境
系统 centos_7 bind * Up to
(excluding)
9.11.4-26.P2.el7_9.4
7
运行在以下环境
系统 amazon_AMI bind * Up to
(excluding)
9.8.2-0.68.rc1.86.amzn1
8
运行在以下环境
系统 amazon_2 bind * Up to
(excluding)
9.11.4-26.P2.amzn2.4
9
运行在以下环境
系统 alpine_edge bind * Up to
(excluding)
9.16.11-r2
10
运行在以下环境
系统 debian_10 bind * Up to
(excluding)
1:9.11.5.P4+dfsg-5.1+deb10u1
11
运行在以下环境
系统 debian_9 bind * Up to
(excluding)
9.10.3.dfsg.P4-12.3+deb9u8
12
运行在以下环境
系统 debian_11 bind * Up to
(excluding)
9.16.11-2
13
运行在以下环境
系统 oracle_6 bind * Up to
(excluding)
9.8.2-0.68.rc1.0.1.el6_10.8
14
运行在以下环境
系统 suse_12_SP5 bind * Up to
(excluding)
9.11.22-3.29.1
15
运行在以下环境
系统 oracle_7 bind * Up to
(excluding)
9.11.4-26.P2.el7_9.4
16
运行在以下环境
系统 oracle_8 bind * Up to
(excluding)
9.11.20-5.el8_3.1
17
运行在以下环境
系统 alibaba_cloud_linux_2.1903 bind * Up to
(excluding)
9.11.4-26.P2.1.al7.4
18
运行在以下环境
系统 opensuse_Leap_15.2 bind * Up to
(excluding)
9.16.6-lp152.14.12.1
19
运行在以下环境
系统 fedora_32 bind * Up to
(excluding)
9.11.28-1.fc32
20
运行在以下环境
系统 fedora_33 bind * Up to
(excluding)
9.11.28-1.fc33
21
运行在以下环境
系统 fedora_34 bind * Up to
(excluding)
9.16.11-5.fc34
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-120 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)
阿里云安全产品覆盖情况