低危 Apache Log4j SMTP Appender SMTPS 证书验证漏洞

CVE编号

CVE-2020-9488

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-28
漏洞描述
Apache Log4j是美国阿帕奇(Apache)软件基金会的一款基于Java的开源日志记录工具。 Apache Log4j中存在安全漏洞,该漏洞源于SmtpAppender没有验证主机名称与SMTPS连接的SSL/TLS证书是否匹配。攻击者可通过实施中间人攻击利用该漏洞拦截SMTPS连接,获取日志消息。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://issues.apache.org/jira/browse/LOG4J2-2819
参考链接
https://issues.apache.org/jira/browse/LOG4J2-2819
https://lists.apache.org/thread.html/r0a2699f724156a558afd1abb6c044fb9132caa6...
https://lists.apache.org/thread.html/r0df3d7a5acb98c57e64ab9266aa21eeee1d9b39...
https://lists.apache.org/thread.html/r1fc73f0e16ec2fa249d3ad39a5194afb9cc5afb...
https://lists.apache.org/thread.html/r22a56beb76dd8cf18e24fda9072f1e05990f49d...
https://lists.apache.org/thread.html/r2721aba31a8562639c4b937150897e24f78f747...
https://lists.apache.org/thread.html/r2f209d271349bafd91537a558a279c08ebcff8f...
https://lists.apache.org/thread.html/r33864a0fc171c1c4bf680645ebb6d4f8057899a...
https://lists.apache.org/thread.html/r393943de452406f0f6f4b3def9f8d3c071f9632...
https://lists.apache.org/thread.html/r3d1d00441c55144a4013adda74b051ae7864128...
https://lists.apache.org/thread.html/r4285398e5585a0456d3d9db021a4fce6e6fcf3e...
https://lists.apache.org/thread.html/r45916179811a32cbaa500f972de9098e6ee80ee...
https://lists.apache.org/thread.html/r48bcd06049c1779ef709564544c3d8a32ae6ee5...
https://lists.apache.org/thread.html/r48efc7cb5aeb4e1f67aaa06fb4b5479a5635d12...
https://lists.apache.org/thread.html/r4d5dc9f3520071338d9ebc26f9f158a43ae28a9...
https://lists.apache.org/thread.html/r4db540cafc5d7232c62e076051ef661d37d3450...
https://lists.apache.org/thread.html/r4ed1f49616a8603832d378cb9d13e7a8b9b2797...
https://lists.apache.org/thread.html/r5a68258e5ab12532dc179edae3d6e87037fa3b5...
https://lists.apache.org/thread.html/r65578f3761a89bc164e8964acd5d913b9f8fd99...
https://lists.apache.org/thread.html/r7641ee788e1eb1be4bb206a7d15f8a64ec6ef23...
https://lists.apache.org/thread.html/r7e5c10534ed06bf805473ac85e8412fe3908a8f...
https://lists.apache.org/thread.html/r7e739f2961753af95e2a3a637828fb88bfca68e...
https://lists.apache.org/thread.html/r8c001b9a95c0bbec06f4457721edd94935a5593...
https://lists.apache.org/thread.html/r8e96c340004b7898cad3204ea51280ef6e4b553...
https://lists.apache.org/thread.html/r9776e71e3c67c5d13a91c1eba0dc025b48b802e...
https://lists.apache.org/thread.html/r9a79175c393d14d760a0ae3731b4a873230a16e...
https://lists.apache.org/thread.html/ra051e07a0eea4943fa104247e69596f094951f5...
https://lists.apache.org/thread.html/ra632b329b2ae2324fabbad5da204c4ec2e171ff...
https://lists.apache.org/thread.html/rbc45eb0f53fd6242af3e666c2189464f848a851...
https://lists.apache.org/thread.html/rbc7642b9800249553f13457e46b813bea1aec99...
https://lists.apache.org/thread.html/rc2dbc4633a6eea1fcbce6831876cfa17b73759a...
https://lists.apache.org/thread.html/rc6b81c013618d1de1b5d6b8c1088aaf87b4bacc...
https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2...
https://lists.apache.org/thread.html/rd55f65c6822ff235eda435d31488cfbb9aa7055...
https://lists.apache.org/thread.html/rd5d58088812cf8e677d99b07f73c654014c524c...
https://lists.apache.org/thread.html/rd8e87c4d69df335d0ba7d815b63be8bd8a6352f...
https://lists.apache.org/thread.html/re024d86dffa72ad800f2848d0c77ed93f0b78ee...
https://lists.apache.org/thread.html/rec34b1cccf907898e7cb36051ffac3ccf1ea89d...
https://lists.apache.org/thread.html/rf1c2a81a08034c688b8f15cf58a4cfab322d000...
https://lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0...
https://lists.debian.org/debian-lts-announce/2021/12/msg00017.html
https://security.netapp.com/advisory/ntap-20200504-0003/
https://www.debian.org/security/2021/dsa-5020
https://www.oracle.com/security-alerts/cpuApr2021.html
https://www.oracle.com/security-alerts/cpuapr2022.html
https://www.oracle.com/security-alerts/cpujan2021.html
https://www.oracle.com/security-alerts/cpujul2020.html
https://www.oracle.com/security-alerts/cpuoct2020.html
https://www.oracle.com/security-alerts/cpuoct2021.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache log4j * Up to
(excluding)
2.13.2
运行在以下环境
应用 oracle communications_application_session_controller 3.9m0p1 -
运行在以下环境
应用 oracle communications_billing_and_revenue_management 12.0.0.3.0 -
运行在以下环境
应用 oracle communications_billing_and_revenue_management 7.5.0.23.0 -
运行在以下环境
应用 oracle communications_offline_mediation_controller 12.0.0.3.0 -
运行在以下环境
应用 oracle communications_services_gatekeeper 7.0 -
运行在以下环境
应用 oracle communications_unified_inventory_management 7.3.0 -
运行在以下环境
应用 oracle communications_unified_inventory_management 7.4.0 -
运行在以下环境
应用 oracle enterprise_manager_for_peoplesoft 13.4.1.1 -
运行在以下环境
应用 oracle financial_services_analytical_applications_infrastructure * From
(including)
8.0.6.0.0
Up to
(including)
8.1.0.0.0
运行在以下环境
应用 oracle financial_services_institutional_performance_analytics 8.0.6 -
运行在以下环境
应用 oracle financial_services_institutional_performance_analytics 8.1.0 -
运行在以下环境
应用 oracle financial_services_institutional_performance_analytics 8.7.0 -
运行在以下环境
应用 oracle financial_services_market_risk_measurement_and_management 8.0.6 -
运行在以下环境
应用 oracle financial_services_market_risk_measurement_and_management 8.0.8 -
运行在以下环境
应用 oracle financial_services_market_risk_measurement_and_management 8.1.0 -
运行在以下环境
应用 oracle financial_services_price_creation_and_discovery 8.0.6 -
运行在以下环境
应用 oracle financial_services_price_creation_and_discovery 8.0.7 -
运行在以下环境
应用 oracle financial_services_retail_customer_analytics 8.0.6 -
运行在以下环境
应用 oracle flexcube_core_banking * From
(including)
11.5.0
Up to
(including)
11.7.0
运行在以下环境
应用 oracle flexcube_core_banking 5.2.0 -
运行在以下环境
应用 oracle flexcube_private_banking 12.0.0 -
运行在以下环境
应用 oracle flexcube_private_banking 12.1.0 -
运行在以下环境
应用 oracle insurance_insbridge_rating_and_underwriting * From
(including)
5.0.0.0
Up to
(including)
5.6.0.0
运行在以下环境
应用 oracle insurance_insbridge_rating_and_underwriting 5.6.1.0 -
运行在以下环境
应用 oracle insurance_policy_administration_j2ee 10.2.0.37 -
运行在以下环境
应用 oracle insurance_policy_administration_j2ee 10.2.4.12 -
运行在以下环境
应用 oracle insurance_policy_administration_j2ee 11.0.2.25 -
运行在以下环境
应用 oracle insurance_policy_administration_j2ee 11.1.0.15 -
运行在以下环境
应用 oracle insurance_policy_administration_j2ee 11.2.0.26 -
运行在以下环境
应用 oracle insurance_rules_palette 10.2.0.37 -
运行在以下环境
应用 oracle insurance_rules_palette 10.2.4.12 -
运行在以下环境
应用 oracle insurance_rules_palette 11.0.2.25 -
运行在以下环境
应用 oracle insurance_rules_palette 11.1.0.15 -
运行在以下环境
应用 oracle insurance_rules_palette 11.2.0.26 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.56 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.57 -
运行在以下环境
应用 oracle peoplesoft_enterprise_peopletools 8.58 -
运行在以下环境
应用 oracle policy_automation * From
(including)
12.2.0
Up to
(including)
12.2.20
运行在以下环境
应用 oracle policy_automation_connector_for_siebel 10.4.6 -
运行在以下环境
应用 oracle policy_automation_for_mobile_devices * From
(including)
12.2.0
Up to
(including)
12.2.20
运行在以下环境
应用 oracle primavera_unifier 18.8 -
运行在以下环境
应用 oracle primavera_unifier 19.12 -
运行在以下环境
应用 oracle retail_advanced_inventory_planning 14.1 -
运行在以下环境
应用 oracle retail_assortment_planning 15.0.3.0 -
运行在以下环境
应用 oracle retail_assortment_planning 16.0.3.0 -
运行在以下环境
应用 oracle retail_bulk_data_integration 15.0.3.0 -
运行在以下环境
应用 oracle retail_bulk_data_integration 16.0.3.0 -
运行在以下环境
应用 oracle retail_integration_bus 14.1 -
运行在以下环境
应用 oracle retail_integration_bus 15.0 -
运行在以下环境
应用 oracle retail_integration_bus 16.0 -
运行在以下环境
应用 oracle retail_order_broker_cloud_service 16.0 -
运行在以下环境
应用 oracle retail_order_broker_cloud_service 18.0 -
运行在以下环境
应用 oracle retail_order_broker_cloud_service 19.0 -
运行在以下环境
应用 oracle retail_order_broker_cloud_service 19.1 -
运行在以下环境
应用 oracle retail_order_broker_cloud_service 19.2 -
运行在以下环境
应用 oracle retail_order_broker_cloud_service 19.3 -
运行在以下环境
应用 oracle retail_predictive_application_server 14.1.3.0 -
运行在以下环境
应用 oracle retail_predictive_application_server 15.0.3.0 -
运行在以下环境
应用 oracle retail_predictive_application_server 16.0.3.0 -
运行在以下环境
应用 oracle spatial_and_graph 12.2.0.1 -
运行在以下环境
应用 oracle spatial_and_graph 18c -
运行在以下环境
应用 oracle spatial_and_graph 19c -
运行在以下环境
应用 oracle utilities_framework * From
(including)
4.3.0.1.0
Up to
(including)
4.3.0.6.0
运行在以下环境
应用 oracle utilities_framework 2.2.0.0.0 -
运行在以下环境
应用 oracle utilities_framework 4.2.0.2.0 -
运行在以下环境
应用 oracle utilities_framework 4.2.0.3.0 -
运行在以下环境
应用 oracle utilities_framework 4.4.0.0.0 -
运行在以下环境
应用 oracle utilities_framework 4.4.0.2.0 -
运行在以下环境
应用 oracle weblogic_server 10.3.6.0.0 -
运行在以下环境
系统 debian_10 apache-log4j2 * Up to
(excluding)
2.15.0-1~deb10u1
运行在以下环境
系统 debian_11 apache-log4j2 * Up to
(including)
2.11.2-1
运行在以下环境
系统 debian_9 apache-log4j2 * Up to
(excluding)
2.12.3-0+deb9u1
运行在以下环境
系统 debian_sid apache-log4j2 * Up to
(including)
2.11.2-1
运行在以下环境
系统 ubuntu_20.04 log4j * Up to
(excluding)
2.16.0-0.20.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况