高危 Oracle MySQL Client信息泄漏漏洞

CVE编号

CVE-2021-2007

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2021-01-21
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Oracle MySQL是一个开源的关系型数据库管理系统。MySQL Client是MySQL客户端,是用于与服务器通信以处理服务器管理的数据库中的信息的程序。

Oracle MySQL Client 5.6.47、5.7.29、8.0.19及更早版本中的C API组件存在未明漏洞。攻击者可利用该漏洞影响机密性。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.oracle.com/security-alerts/cpujan2021.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 oracle mysql * From
(including)
5.6.0
Up to
(including)
5.6.47
运行在以下环境
应用 oracle mysql * From
(including)
5.7.0
Up to
(including)
5.7.29
运行在以下环境
应用 oracle mysql * From
(including)
8.0.0
Up to
(including)
8.0.19
运行在以下环境
系统 alibaba_cloud_linux_2.1903 mysql * Up to
(excluding)
3.1.11-2.1.al8
运行在以下环境
系统 centos_8 mysql * Up to
(excluding)
3.1.11-2.el8_3
运行在以下环境
系统 fedora_32 mysql * Up to
(excluding)
8.0.23-1.fc32
运行在以下环境
系统 fedora_32_Modular mysql * Up to
(excluding)
8.0-3220210504011648.43bbeeef
运行在以下环境
系统 fedora_33 mysql * Up to
(excluding)
8.0.23-1.fc33
运行在以下环境
系统 fedora_33_Modular mysql * Up to
(excluding)
8.0-3320210504011648.601d93de
运行在以下环境
系统 fedora_34_Modular mysql * Up to
(excluding)
8.0-3420210504011648.058368ca
运行在以下环境
系统 redhat_7 mariadb * Up to
(excluding)
1:5.5.65-1.el7
运行在以下环境
系统 redhat_8 mysql * Up to
(excluding)
3.1.11-2.el8_3
运行在以下环境
系统 ubuntu_16.04 mysql * Up to
(excluding)
5.7.30-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts mysql-5.7 * Up to
(excluding)
5.7.30-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04 mysql * Up to
(excluding)
5.7.30-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts mysql-5.7 * Up to
(excluding)
5.7.30-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_20.04 mysql * Up to
(excluding)
8.0.20-0ubuntu0.20.04.1
阿里云评分
7.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况