中危 ImageMagick up to 7.0.10-55 MagickCore/gem.c divide by zero

CVE编号

CVE-2021-20176

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2021-02-06
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
ImageMagick是一款用来创建、编辑、合成图片的软件,可以读取、转换、写入多种格式的图片。ImageMagick 7.0.10-56之前版本中的MagickCore/gem.c存在安全漏洞。攻击者可利用该漏洞会以数学除零的形式触发未定义的行为。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:https://download.imagemagick.org/ImageMagick/download/beta/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick * Up to
(excluding)
7.0.10-56
运行在以下环境
系统 alpine_3.13 imagemagick * Up to
(excluding)
7.0.10.57-r0
运行在以下环境
系统 alpine_3.14 imagemagick * Up to
(excluding)
7.0.10.57-r0
运行在以下环境
系统 alpine_3.15 imagemagick * Up to
(excluding)
7.0.10.57-r0
运行在以下环境
系统 alpine_3.16 imagemagick * Up to
(excluding)
7.0.10.57-r0
运行在以下环境
系统 alpine_edge imagemagick * Up to
(excluding)
7.0.11.1-r0
运行在以下环境
系统 debian_10 imagemagick * Up to
(including)
6.9.10.23+dfsg-2.1+deb10u1
运行在以下环境
系统 debian_9 imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-11+deb9u12
运行在以下环境
系统 opensuse_Leap_15.2 imagemagick * Up to
(excluding)
7.0.7.34-lp152.12.18.1
运行在以下环境
系统 opensuse_Leap_15.3 imagemagick * Up to
(excluding)
7.0.7.34-10.18.1
运行在以下环境
系统 suse_12_SP5 imagemagick * Up to
(excluding)
6.8.8.1-71.159.2
运行在以下环境
系统 ubuntu_16.04 imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.16+esm2
运行在以下环境
系统 ubuntu_18.04 imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-16ubuntu6.11
运行在以下环境
系统 ubuntu_18.04.5_lts imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-16ubuntu6.11
运行在以下环境
系统 ubuntu_20.04 imagemagick * Up to
(excluding)
8:6.9.10.23+dfsg-2.1ubuntu11.4
阿里云评分
4.1
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-369 除零错误
阿里云安全产品覆盖情况