低危 linux linux_kernel 输入验证不恰当

CVE编号

CVE-2021-20194

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-02-24
漏洞描述
Linux kernel是一种计算机操作系统内核,以C语言和汇编语言写成,符合POSIX标准,按GNU通用公共许可证发行

linux kernel 5.2以上版本中的__cgroup_bpf_run_filter_getsockopt()函数存在堆溢出漏洞。该漏洞源于BPF执行。攻击者可利用该漏洞导致拒绝服务或提升权限。
解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
https://www.kernel.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat openshift_container_platform 4.4 -
运行在以下环境
应用 redhat openshift_container_platform 4.5 -
运行在以下环境
应用 redhat openshift_container_platform 4.6 -
运行在以下环境
系统 centos_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 fedora_32 kernel * Up to
(excluding)
5.10.15-100.fc32
运行在以下环境
系统 fedora_33 kernel * Up to
(excluding)
5.10.15-200.fc33
运行在以下环境
系统 linux linux_kernel * From
(excluding)
5.2
运行在以下环境
系统 oracle_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 redhat_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_18.04 kernel * Up to
(excluding)
5.4.0-1033.36~18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_20.04 kernel * Up to
(excluding)
5.4.0-1033.36
运行在以下环境
系统 ubuntu_21.10 kernel * Up to
(excluding)
5.11.0-1006.6
阿里云评分
3.1
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况