低危 ZeroMQ存在未明漏洞

CVE编号

CVE-2021-20236

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-05-28
漏洞描述
ZeroMQ是一个轻量级分布式消息传递引擎核心库。

ZeroMQ server 4.3.3之前版本存在安全漏洞,该漏洞源于允许恶意客户端通过发送精心设计的主题订阅请求,然后取消订阅,从而导致服务器上的堆栈缓冲区溢出。目前没有详细漏洞细节提供。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/zeromq/libzmq/security/advisories/GHSA-qq65-x72m-9wr8
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ceph_storage 2.0 -
运行在以下环境
应用 zeromq zeromq * Up to
(excluding)
4.3.3
运行在以下环境
系统 debian_10 zeromq3 * Up to
(excluding)
4.3.1-4+deb10u2
运行在以下环境
系统 debian_9 zeromq3 * Up to
(excluding)
4.2.1-4+deb9u2
阿里云评分
3.1
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-120 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)
CWE-787 跨界内存写
阿里云安全产品覆盖情况