低危 upx_project upx 内存缓冲区边界内操作的限制不恰当

CVE编号

CVE-2021-20285

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-03-27
漏洞描述
UPX是一款开源可执行文件打包程序,支持来自不同操作系统的多种文件格式。

UPX 3.96版本中的p_lx_elf.cpp中的canPack存在拒绝服务漏洞。攻击者可通过特制ELF利用该漏洞导致应用程序崩溃。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:https://github.com/upx/upx/commit/3781df9da23840e596d5e9e8493f22666802fe6c
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 upx_project upx 3.96 -
运行在以下环境
系统 alpine_3.13 upx * Up to
(excluding)
3.96-r1
运行在以下环境
系统 alpine_3.14 upx * Up to
(excluding)
3.96-r1
运行在以下环境
系统 alpine_3.15 upx * Up to
(excluding)
3.96-r1
运行在以下环境
系统 alpine_edge upx * Up to
(excluding)
3.96-r1
运行在以下环境
系统 debian_10 upx * Up to
(excluding)
3.95-1
运行在以下环境
系统 debian_11 upx * Up to
(excluding)
3.96-2
运行在以下环境
系统 debian_12 upx * Up to
(excluding)
3.96-3
运行在以下环境
系统 debian_9 upx * Up to
(excluding)
3.91-4
运行在以下环境
系统 debian_sid upx * Up to
(excluding)
3.96-3
运行在以下环境
系统 fedora_32 upx * Up to
(excluding)
3.96-8.fc32
运行在以下环境
系统 fedora_33 upx * Up to
(excluding)
3.96-8.fc33
运行在以下环境
系统 fedora_34 upx * Up to
(excluding)
3.96-8.fc34
运行在以下环境
系统 fedora_EPEL_7 upx * Up to
(excluding)
3.96-8.el7
运行在以下环境
系统 fedora_EPEL_8 upx * Up to
(excluding)
3.96-8.el8
阿里云评分
3.3
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况