中危 Vmware Spring Framework 安全漏洞

CVE编号

CVE-2021-22096

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-11-26
漏洞描述
Vmware Spring Framework是美国威睿(Vmware)公司的一套开源的Java、JavaEE应用程序框架。该框架可帮助开发人员构建高质量的应用。

Vmware Spring Framework 存在安全漏洞,该漏洞源于通过日志注入绕过 Spring Framework 的访问限制,以更改数据。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://spring.io/blog/2021/10/26/security-reports-for-spring-framework-spring-data-rest-spring-amqp-and-spring-cloud-openfeign
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vmware spring_framework * From
(including)
5.2.0
Up to
(including)
5.2.17
运行在以下环境
应用 vmware spring_framework * From
(including)
5.3.0
Up to
(including)
5.3.10
运行在以下环境
系统 debian_10 libspring-java * Up to
(including)
4.3.22-4
运行在以下环境
系统 debian_11 libspring-java * Up to
(including)
4.3.30-1
运行在以下环境
系统 debian_12 libspring-java * Up to
(including)
4.3.30-1
运行在以下环境
系统 debian_9 libspring-java * Up to
(including)
4.3.5-1
运行在以下环境
系统 debian_sid libspring-java * Up to
(including)
4.3.30-1
阿里云评分
6.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况