严重 Gitlab exiftool 远程命令执行漏洞在野利用(CVE-2021-22205)

CVE编号

CVE-2021-22205

利用情况

漏洞武器化

补丁情况

官方补丁

披露时间

2021-10-28
该漏洞已被黑客武器化,用于大规模蠕虫传播、勒索挖矿,建议您立即关注并修复。
漏洞描述
2021年10月28日,阿里云应急响应中心监测到近日互联网上披露 CVE-2021-22205 Gitlab exiftool 远程命令执行漏洞在野利用事件。

GitLab 是由GitLab Inc.开发,一款基于Git 的完全集成的软件开发平台。2021年4月14日 Gitlab 官方发布安全更新,披露了CVE-2021-22205 Gitlab exiftool 远程命令执行漏洞,攻击者通过上传恶意图片可触发远程命令执行,控制服务器。2021年10月,阿里云应急响应中心监测到互联网上披露 CVE-2021-22205 Gitlab exiftool 远程命令执行漏洞在野利用事件及其新型利用方式,由于 Gitlab 某些端点路径无需授权,攻击者可在无需认证的情况下完成图片上传,从而执行任意命令。阿里云应急响应中心提醒 Gitlab 用户尽快采取安全措施阻止漏洞攻击。

影响版本

11.9 <= GitLab(CE/EE)< 13.8.8

13.9 <= GitLab(CE/EE)< 13.9.6

13.10 <= GitLab(CE/EE)< 13.10.3

安全版本

GitLab(CE/EE) 13.8.8

GitLab(CE/EE) 13.9.6

GitLab(CE/EE) 13.10.3
解决建议
1、利用阿里云安全组功能设置 Gitlab 仅对可信地址开放
2、尽快升级Gitlab至最新版本。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gitlab gitlab * From
(including)
11.9.0
Up to
(excluding)
13.8.8
运行在以下环境
应用 gitlab gitlab * From
(including)
13.10.0
Up to
(excluding)
13.10.3
运行在以下环境
应用 gitlab gitlab * From
(including)
13.9.0
Up to
(excluding)
13.9.6
运行在以下环境
系统 debian_sid gitlab * Up to
(excluding)
13.4.7-2
阿里云评分
9.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    漏洞武器化
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况