中危 Node Core 安全漏洞

CVE编号

CVE-2021-22884

利用情况

暂无

补丁情况

没有补丁

披露时间

2021-03-03
漏洞描述
Nodejs Core是OpenJS(Openjs)基金会的一个编译到Nodejs中的核心模块。该模块为Nodejs提供底层的TCP,HTTP,DNS,文件系统,子进程等功能支持。
Node Core 存在安全漏洞,攻击者可利用该漏洞可以通过DNS重新绑定节点核心的Localhost6,利用漏洞来运行代码。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://bugzilla.redhat.com/show_bug.cgi?id=1932024
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nodejs node.js * From
(including)
10.0.0
Up to
(excluding)
10.24.0
运行在以下环境
应用 nodejs node.js * From
(including)
12.0.0
Up to
(excluding)
12.21.0
运行在以下环境
应用 nodejs node.js * From
(including)
14.0.0
Up to
(excluding)
14.16.0
运行在以下环境
应用 nodejs node.js * From
(including)
15.0.0
Up to
(excluding)
15.10.0
运行在以下环境
系统 alibaba_cloud_linux_2.1903 nodejs * Up to
(excluding)
14.16.0-2.1.al8
运行在以下环境
系统 alpine_3.11 nodejs * Up to
(excluding)
12.21.0-r0
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.21.0-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
15.10.0-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
15.10.0-r0
运行在以下环境
系统 alpine_3.15 nodejs * Up to
(excluding)
15.10.0-r0
运行在以下环境
系统 alpine_3.16 nodejs * Up to
(excluding)
15.10.0-r0
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
15.10.0-r0
运行在以下环境
系统 centos_8 nodejs * Up to
(excluding)
10.24.0-1.module+el8.3.0+10166+b07ac28e
运行在以下环境
系统 debian_10 nodejs * Up to
(excluding)
10.24.0~dfsg-1~deb10u1
运行在以下环境
系统 debian_11 nodejs * Up to
(including)
12.20.2~dfsg-2
运行在以下环境
系统 debian_9 nodejs * Up to
(including)
4.8.2~dfsg-1
运行在以下环境
系统 fedora_32 nodejs * Up to
(excluding)
12.21.0-2.fc32
运行在以下环境
系统 fedora_32_Modular nodejs * Up to
(excluding)
10-3220210223224027.43bbeeef
运行在以下环境
系统 fedora_32_Modular nodejs * Up to
(excluding)
15-3220210303194449.43bbeeef
运行在以下环境
系统 fedora_33 nodejs * Up to
(excluding)
14.16.0-1.fc33
运行在以下环境
系统 fedora_33_Modular nodejs * Up to
(excluding)
10-3320210223224027.601d93de
运行在以下环境
系统 fedora_33_Modular nodejs * Up to
(excluding)
15-3320210303194449.601d93de
运行在以下环境
系统 fedora_34 nodejs * Up to
(excluding)
14.16.0-1.fc34
运行在以下环境
系统 fedora_34_Modular nodejs * Up to
(excluding)
10-3420210223224027.058368ca
运行在以下环境
系统 fedora_34_Modular nodejs * Up to
(excluding)
15-3420210303194449.058368ca
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
10.24.0-lp152.2.12.1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
12.21.0-lp152.3.12.1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
14.16.0-lp152.8.1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
8.17.0-lp152.3.11.1
运行在以下环境
系统 oracle_8 nodejs * Up to
(excluding)
23-3.module+el8.3.0+7818+6cd30d85
运行在以下环境
系统 redhat_8 nodejs * Up to
(excluding)
10.24.0-1.module+el8.3.0+10166+b07ac28e
运行在以下环境
系统 ubuntu_8 nodejs * Up to
(excluding)
10.24.0-1.module+el8.3.0+10166+b07ac28e
阿里云评分
6.8
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况