低危 Nodejs 缓冲区错误漏洞

CVE编号

CVE-2021-22918

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-12
漏洞描述
nodejs是是一个基于ChromeV8引擎的JavaScript运行环境通过对Chromev8引擎进行了封装以及使用事件驱动和非阻塞IO的应用让Javascript开发高性能的后台应用成为了可能。
Nodejs 存在缓冲区错误漏洞,该漏洞源于程序的uv__idna_toascii()函数中存在越界读取漏洞。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://nodejs.org/en/blog/vulnerability/july-2021-security-releases/。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nodejs node.js * From
(including)
12.0.0
Up to
(excluding)
12.22.2
运行在以下环境
应用 nodejs node.js * From
(including)
14.0.0
Up to
(excluding)
14.17.2
运行在以下环境
应用 nodejs node.js * From
(including)
16.0.0
Up to
(including)
16.4.1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 nodejs * Up to
(excluding)
14.17.3-2.1.al8
运行在以下环境
系统 alpine_3.11 nodejs * Up to
(excluding)
12.22.2-r0
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.22.2-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
14.17.3-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
14.17.3-r0
运行在以下环境
系统 centos_8 nodejs * Up to
(excluding)
1.41.1-1.el8_4
运行在以下环境
系统 debian_10 nodejs * Up to
(excluding)
1.24.1-1+deb10u1
运行在以下环境
系统 debian_11 nodejs * Up to
(including)
1.40.0-1
运行在以下环境
系统 debian_9 nodejs * Up to
(including)
1.9.1-3
运行在以下环境
系统 debian_sid nodejs * Up to
(including)
1.40.0-1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
10.24.1-lp152.2.15.1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
12.22.2-lp152.3.15.1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
14.17.2-lp152.11.1
运行在以下环境
系统 opensuse_Leap_15.3 nodejs * Up to
(excluding)
10.24.1-1.36.1
运行在以下环境
系统 opensuse_Leap_15.3 nodejs * Up to
(excluding)
12.22.2-4.16.1
运行在以下环境
系统 opensuse_Leap_15.3 nodejs * Up to
(excluding)
14.17.2-5.12.1
运行在以下环境
系统 oracle_8 nodejs * Up to
(excluding)
1.41.1-1.el8_4
运行在以下环境
系统 redhat_8 nodejs * Up to
(excluding)
1.41.1-1.el8_4
运行在以下环境
系统 ubuntu_20.04 nodejs * Up to
(excluding)
1.34.2-1ubuntu1.3
运行在以下环境
系统 ubuntu_21.04 nodejs * Up to
(excluding)
1.40.0-1ubuntu0.1
运行在以下环境
系统 ubuntu_21.10 libuv * Up to
(excluding)
1.40.0-2
运行在以下环境
系统 ubuntu_22.04 libuv * Up to
(excluding)
1.40.0-2
阿里云评分
3.4
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况