低危 Arch Linux 信任管理问题漏洞

CVE编号

CVE-2021-22924

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-21
漏洞描述
Arch Linux是Arch开源的一个应用系统。一个轻量级且灵活的Linux®发行版,试图使它保持简单。
Arch Linux中存在信任管理问题漏洞,该漏洞源于产品的配置匹配函数不能正确处理 issuer cert 并且比较路径时逻辑错误。攻击者可通过该漏洞访问系统的敏感信息。

受影响系统:Arch Linux < 7.78.0

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

https://security.archlinux.org/advisory/ASA-202107-63
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx libcurl * From
(including)
7.10.4
Up to
(excluding)
7.77.0
运行在以下环境
应用 netapp clustered_data_ontap - -
运行在以下环境
应用 netapp solidfire_&_hci_management_node - -
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.78.0-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.78.0-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.78.0-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.78.0-r0
运行在以下环境
系统 alpine_3.16 curl * Up to
(excluding)
7.78.0-r0
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.78.0-r0
运行在以下环境
系统 amazon_2 curl * Up to
(excluding)
7.76.1-7.amzn2.0.2
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.61.1-12.99.amzn1
运行在以下环境
系统 centos_8 curl * Up to
(excluding)
7.61.1-18.el8_4.1
运行在以下环境
系统 debian_10 curl * Up to
(including)
7.64.0-4+deb10u2
运行在以下环境
系统 debian_11 curl * Up to
(including)
7.74.0-1.3+deb11u1
运行在以下环境
系统 debian_12 curl * Up to
(including)
7.74.0-1.3
运行在以下环境
系统 debian_9 curl * Up to
(excluding)
7.52.1-5+deb9u15
运行在以下环境
系统 debian_sid curl * Up to
(including)
7.74.0-1.3
运行在以下环境
系统 fedora_33 curl * Up to
(excluding)
7.71.1-10.fc33
运行在以下环境
系统 fedora_34 curl * Up to
(excluding)
7.76.1-7.fc34
运行在以下环境
系统 opensuse_Leap_15.2 curl * Up to
(excluding)
7.66.0-lp152.3.21.1
运行在以下环境
系统 opensuse_Leap_15.3 curl * Up to
(excluding)
7.66.0-4.22.1
运行在以下环境
系统 oracle_8 curl * Up to
(excluding)
7.61.1-18.el8_4.1
运行在以下环境
系统 redhat_8 curl * Up to
(excluding)
7.61.1-18.el8_4.1
运行在以下环境
系统 suse_12_SP5 curl * Up to
(excluding)
7.60.0-11.23.1
运行在以下环境
系统 ubuntu_18.04 curl * Up to
(excluding)
7.58.0-2ubuntu3.14
运行在以下环境
系统 ubuntu_18.04.5_lts curl * Up to
(excluding)
7.58.0-2ubuntu3.14
运行在以下环境
系统 ubuntu_20.04 curl * Up to
(excluding)
7.68.0-1ubuntu2.6
运行在以下环境
系统 ubuntu_21.04 curl * Up to
(excluding)
7.74.0-1ubuntu2.1
运行在以下环境
系统 ubuntu_21.10 curl * Up to
(excluding)
7.74.0-1.2ubuntu4
运行在以下环境
系统 ubuntu_22.04 curl * Up to
(excluding)
7.74.0-1.2ubuntu4
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-706 使用不正确的解析名称或索引
阿里云安全产品覆盖情况