中危 HAXX Haxx curl 安全漏洞

CVE编号

CVE-2021-22946

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-16
漏洞描述
HAXX Haxx curl是瑞典Haxx(HAXX)公司的一套利用URL语法在命令行下工作的文件传输工具。该工具支持文件上传和下载,并包含一个用于程序开发的libcurl(客户端URL传输库。
Haxx curl 存在安全漏洞,目前尚无此漏洞的相关信息。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://curl.se/docs/CVE-2021-22946.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl * From
(including)
7.20.0
Up to
(excluding)
7.79.0
运行在以下环境
系统 alibaba_cloud_linux_2.1903 curl * Up to
(excluding)
7.61.1-18.1.al8.2
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.79.0-r0
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.79.0-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.79.0-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.79.0-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.79.0-r0
运行在以下环境
系统 alpine_3.16 curl * Up to
(excluding)
7.79.0-r0
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.79.0-r0
运行在以下环境
系统 amazon_2 curl * Up to
(excluding)
7.79.1-1.amzn2.0.1
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.61.1-12.100.amzn1
运行在以下环境
系统 centos_8 curl * Up to
(excluding)
7.61.1-18.el8_4.2
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 curl * Up to
(including)
7.64.0-4+deb10u2
运行在以下环境
系统 debian_11 curl * Up to
(including)
7.74.0-1.3+deb11u1
运行在以下环境
系统 debian_12 curl * Up to
(including)
7.74.0-1.3
运行在以下环境
系统 debian_9 curl * Up to
(excluding)
7.52.1-5+deb9u16
运行在以下环境
系统 debian_sid curl * Up to
(including)
7.74.0-1.3
运行在以下环境
系统 fedoraproject fedora 33 -
运行在以下环境
系统 fedora_33 curl * Up to
(excluding)
7.71.1-11.fc33
运行在以下环境
系统 fedora_34 curl * Up to
(excluding)
7.76.1-12.fc34
运行在以下环境
系统 fedora_35 curl * Up to
(excluding)
7.79.0-4.fc35
运行在以下环境
系统 opensuse_Leap_15.2 curl * Up to
(excluding)
7.66.0-lp152.3.24.1
运行在以下环境
系统 opensuse_Leap_15.3 curl * Up to
(excluding)
7.66.0-4.27.1
运行在以下环境
系统 oracle_8 curl * Up to
(excluding)
7.61.1-18.el8_4.2
运行在以下环境
系统 redhat_8 curl * Up to
(excluding)
7.61.1-18.el8_4.2
运行在以下环境
系统 suse_12_SP5 curl * Up to
(excluding)
7.60.0-11.28.1
运行在以下环境
系统 ubuntu_14.04 curl * Up to
(excluding)
7.35.0-1ubuntu2.20+esm8
运行在以下环境
系统 ubuntu_16.04 curl * Up to
(excluding)
7.47.0-1ubuntu2.19+esm1
运行在以下环境
系统 ubuntu_18.04 curl * Up to
(excluding)
7.58.0-2ubuntu3.15
运行在以下环境
系统 ubuntu_18.04.5_lts curl * Up to
(excluding)
7.58.0-2ubuntu3.15
运行在以下环境
系统 ubuntu_20.04 curl * Up to
(excluding)
7.68.0-1ubuntu2.7
运行在以下环境
系统 ubuntu_21.04 curl * Up to
(excluding)
7.74.0-1ubuntu2.3
运行在以下环境
系统 ubuntu_21.10 curl * Up to
(excluding)
7.74.0-1.3ubuntu2
运行在以下环境
系统 ubuntu_22.04 curl * Up to
(excluding)
7.74.0-1.3ubuntu2
阿里云评分
5.1
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-319 敏感数据的明文传输
阿里云安全产品覆盖情况