中危 Nodejs Core 环境问题漏洞

CVE编号

CVE-2021-22959

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-11-15
漏洞描述
Nodejs Core是OpenJS(Openjs)基金会的一个编译到Nodejs中的核心模块。该模块为Nodejs提供底层的TCP,HTTP,DNS,文件系统,子进程等功能支持。

Nodejs Core 存在安全漏洞,该漏洞源于攻击者可以通过 HTTP 请求走私绕过 Node Core 的访问限制,以读取或更改数据。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://vigilance.fr/vulnerability/Node-Core-read-write-access-via-HTTP-Request-Smuggling-36650
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 llhttp llhttp * Up to
(excluding)
2.1.4
运行在以下环境
应用 llhttp llhttp * From
(including)
3.0.0
Up to
(excluding)
6.0.6
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.22.10-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
14.18.1-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
14.18.1-r0
运行在以下环境
系统 alpine_3.15 nodejs * Up to
(excluding)
14.18.1-r0
运行在以下环境
系统 alpine_3.16 nodejs * Up to
(excluding)
16.11.1-r0
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
14.18.1-r0
运行在以下环境
系统 debian_10 nodejs * Up to
(including)
10.24.0~dfsg-1~deb10u1
运行在以下环境
系统 debian_11 nodejs * Up to
(excluding)
12.22.12~dfsg-1~deb11u1
运行在以下环境
系统 debian_12 nodejs * Up to
(including)
12.22.5~dfsg-5
运行在以下环境
系统 debian_9 nodejs * Up to
(including)
4.8.2~dfsg-1
运行在以下环境
系统 fedora_33 nodejs * Up to
(excluding)
14.18.1-1.fc33
运行在以下环境
系统 fedora_33_Modular nodejs * Up to
(excluding)
14-3320211014121918.601d93de
运行在以下环境
系统 fedora_34 nodejs * Up to
(excluding)
14.18.1-1.fc34
运行在以下环境
系统 fedora_34_Modular nodejs * Up to
(excluding)
12-3420211014123813.058368ca
运行在以下环境
系统 fedora_35 nodejs * Up to
(excluding)
16.11.1-1.fc35
运行在以下环境
系统 fedora_35_Modular nodejs * Up to
(excluding)
14-3520211014121918.f27b74a8
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
14.18.1-lp152.17.1
运行在以下环境
系统 opensuse_Leap_15.3 nodejs * Up to
(excluding)
12.22.7-4.22.1
运行在以下环境
系统 oracle_8 nodejs * Up to
(excluding)
2.0.15-1.module+el8.5.0+20457+52828f44
阿里云评分
6.3
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-444 HTTP请求的解释不一致性(HTTP请求私运)
阿里云安全产品覆盖情况