中危 F5 NGINX Controller 安全漏洞

CVE编号

CVE-2021-23017

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2021-05-26
漏洞描述
F5 NGINX Controller是美国F5公司的一款用于NGINX的集中式监视和管理平台。该平台支持使用可视化界面管理多个NGINX实例。
F5 NGINX Controller存在安全漏洞,该漏洞允许攻击者从DNS服务器伪造UDP数据包造成1-byte的内存覆盖,导致工作进程崩溃或潜在的其他影响。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://www.nginx.com/blog/updating-nginx-dns-resolver-vulnerability-cve-2021-23017/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * Up to
(including)
1.20.0
运行在以下环境
系统 alibaba_cloud_linux_2.1903 nginx * Up to
(excluding)
1.18.0-3.1.al8.1
运行在以下环境
系统 alpine_3.10 nginx * Up to
(excluding)
1.16.1-r3
运行在以下环境
系统 alpine_3.11 nginx * Up to
(excluding)
1.16.1-r7
运行在以下环境
系统 alpine_3.12 nginx * Up to
(excluding)
1.18.0-r2
运行在以下环境
系统 alpine_3.13 nginx * Up to
(excluding)
1.18.0-r14
运行在以下环境
系统 alpine_3.14 nginx * Up to
(excluding)
1.20.1-r0
运行在以下环境
系统 alpine_3.15 nginx * Up to
(excluding)
1.20.1-r0
运行在以下环境
系统 alpine_3.16 nginx * Up to
(excluding)
1.20.1-r0
运行在以下环境
系统 alpine_edge nginx * Up to
(excluding)
1.20.1-r0
运行在以下环境
系统 amazon_AMI nginx * Up to
(excluding)
1.18.0-1.43.amzn1
运行在以下环境
系统 centos_8 nginx * Up to
(excluding)
1.16.1-2.module+el8.4.0+11155+68135136.1
运行在以下环境
系统 debian_10 nginx * Up to
(excluding)
1.14.2-2+deb10u4
运行在以下环境
系统 debian_9 nginx * Up to
(excluding)
1.10.3-1+deb9u6
运行在以下环境
系统 fedora_33 nginx * Up to
(excluding)
1.20.1-2.fc33
运行在以下环境
系统 fedora_34 nginx * Up to
(excluding)
1.20.1-2.fc34
运行在以下环境
系统 fedora_EPEL_7 nginx * Up to
(excluding)
1.20.1-1.el7
运行在以下环境
系统 fedora_EPEL_7 nginx * Up to
(excluding)
1.20.1-2.el7
运行在以下环境
系统 opensuse_Leap_15.2 nginx * Up to
(excluding)
1.16.1-lp152.2.3.1
运行在以下环境
系统 opensuse_Leap_15.3 nginx * Up to
(excluding)
1.19.8-3.3.1
运行在以下环境
系统 oracle_8 nginx * Up to
(excluding)
1.18.0-3.0.1.module+el8.4.0+20183+8c128c59.1
运行在以下环境
系统 redhat_8 nginx * Up to
(excluding)
1.16.1-2.module+el8.4.0+11155+68135136.1
运行在以下环境
系统 ubuntu_14.04 nginx * Up to
(excluding)
1.4.6-1ubuntu3.9+esm2
运行在以下环境
系统 ubuntu_14.04.6_lts nginx * Up to
(excluding)
1.4.6-1ubuntu3.9+esm2
运行在以下环境
系统 ubuntu_16.04 nginx * Up to
(excluding)
1.10.3-0ubuntu0.16.04.5+esm1
运行在以下环境
系统 ubuntu_18.04 nginx * Up to
(excluding)
1.14.0-0ubuntu1.9
运行在以下环境
系统 ubuntu_18.04.5_lts nginx * Up to
(excluding)
1.14.0-0ubuntu1.9
运行在以下环境
系统 ubuntu_20.04 nginx * Up to
(excluding)
1.18.0-0ubuntu1.2
运行在以下环境
系统 ubuntu_21.04 nginx * Up to
(excluding)
1.18.0-6ubuntu8.2
运行在以下环境
系统 ubuntu_21.10 nginx * Up to
(excluding)
1.18.0-6ubuntu9
运行在以下环境
系统 ubuntu_22.04 nginx * Up to
(excluding)
1.18.0-6ubuntu9
阿里云评分
5.6
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-193 Off-by-one错误
CWE-787 跨界内存写
阿里云安全产品覆盖情况