低危 sudo_project sudo 在文件访问前对链接解析不恰当(链接跟随)

CVE编号

CVE-2021-23239

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-01-12
漏洞描述
The sudoedit personality of Sudo before 1.9.5 may allow a local unprivileged user to perform arbitrary directory-existence tests by winning a sudo_edit.c race condition in replacing a user-controlled directory by a symlink to an arbitrary path.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp hci_management_node - -
运行在以下环境
应用 netapp solidfire - -
运行在以下环境
应用 sudo_project sudo * Up to
(excluding)
1.8.32
运行在以下环境
应用 sudo_project sudo * From
(including)
1.9.0
Up to
(excluding)
1.9.5
运行在以下环境
系统 alpine_3.10 sudo * Up to
(excluding)
1.9.5p2-r0
运行在以下环境
系统 alpine_3.11 sudo * Up to
(excluding)
1.9.5p2-r0
运行在以下环境
系统 alpine_3.12 sudo * Up to
(excluding)
1.9.5-r0
运行在以下环境
系统 alpine_3.13 sudo * Up to
(excluding)
1.9.5-r0
运行在以下环境
系统 alpine_3.14 sudo * Up to
(excluding)
1.9.5-r0
运行在以下环境
系统 alpine_3.15 sudo * Up to
(excluding)
1.9.5-r0
运行在以下环境
系统 alpine_edge sudo * Up to
(excluding)
1.9.5-r0
运行在以下环境
系统 centos_8 sudo * Up to
(excluding)
1.8.29-7.el8
运行在以下环境
系统 debian_10 sudo * Up to
(excluding)
1.8.27-1+deb10u3
运行在以下环境
系统 debian_11 sudo * Up to
(excluding)
1.9.4p2-2
运行在以下环境
系统 debian_9 sudo * Up to
(excluding)
1.8.19p1-2.1+deb9u2
运行在以下环境
系统 fedora_32 sudo * Up to
(excluding)
1.9.5p2-1.fc32
运行在以下环境
系统 fedora_33 sudo * Up to
(excluding)
1.9.5p1-1.fc33
运行在以下环境
系统 opensuse_Leap_15.1 sudo * Up to
(excluding)
1.8.22-lp151.5.12.1
运行在以下环境
系统 opensuse_Leap_15.2 sudo * Up to
(excluding)
1.8.22-lp152.8.6.1
运行在以下环境
系统 oracle_8 sudo * Up to
(excluding)
1.8.29-7.el8
运行在以下环境
系统 redhat_8 sudo * Up to
(excluding)
1.8.29-7.el8
运行在以下环境
系统 suse_12_SP5 sudo * Up to
(excluding)
1.8.27-4.6.1
运行在以下环境
系统 ubuntu_16.04 sudo * Up to
(excluding)
1.8.16-0ubuntu1.10
运行在以下环境
系统 ubuntu_18.04 sudo * Up to
(excluding)
1.8.21p2-3ubuntu1.4
运行在以下环境
系统 ubuntu_20.04 sudo * Up to
(excluding)
1.8.31-1ubuntu1.2
运行在以下环境
系统 ubuntu_21.04 sudo * Up to
(excluding)
1.9.4p2-2ubuntu2
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-59 在文件访问前对链接解析不恰当(链接跟随)
阿里云安全产品覆盖情况