低危 node-open-graph 安全漏洞

CVE编号

CVE-2021-2341

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-08-08
漏洞描述
node-open-graph是开源的Node.js的Open Graph实现。
node-open-graph 0.2.6 之前版本存在安全漏洞,攻击者可以使用 __proto__ 或构造函数负载来欺骗函数 parse 以添加或修改 Object.prototype 的属性。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/samholmes/node-open-graph/commit/a0cef507a90adaac7dbbe9c404f09a50bdefb348
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 oracle graalvm 20.3.2 -
运行在以下环境
应用 oracle graalvm 21.1.0 -
运行在以下环境
应用 oracle openjdk 11.0.11 -
运行在以下环境
应用 oracle openjdk 16.0.1 -
运行在以下环境
应用 oracle openjdk 7 -
运行在以下环境
应用 oracle openjdk 8 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 openjdk-8 * Up to
(excluding)
11.0.12.0.7-0.1.al7
运行在以下环境
系统 alpine_3.14 openjdk-8 * Up to
(excluding)
11.0.12_p7-r0
运行在以下环境
系统 alpine_3.15 openjdk-8 * Up to
(excluding)
8.302.08-r0
运行在以下环境
系统 alpine_3.16 openjdk-8 * Up to
(excluding)
8.302.08-r0
运行在以下环境
系统 alpine_edge openjdk-8 * Up to
(excluding)
7.311.2.6.27-r0
运行在以下环境
系统 amazon_2 openjdk-8 * Up to
(excluding)
1.8.0-openjdk-debuginfo-1.8.0.302.b08-0.amzn2.0.1
运行在以下环境
系统 amazon_AMI openjdk-8 * Up to
(excluding)
1.8.0-openjdk-devel-1.8.0.302.b08-0.67.amzn1
运行在以下环境
系统 centos_7 openjdk-8 * Up to
(excluding)
11.0.12.0.7-0.el7_9
运行在以下环境
系统 centos_8 openjdk-8 * Up to
(excluding)
11.0.12.0.7-0.el8_4
运行在以下环境
系统 debian_10 openjdk-8 * Up to
(excluding)
11.0.12+7-2~deb10u1
运行在以下环境
系统 debian_11 openjdk-8 * Up to
(including)
11.0.11+9-1
运行在以下环境
系统 debian_9 openjdk-8 * Up to
(excluding)
8u302-b08-1~deb9u1
运行在以下环境
系统 debian_sid openjdk-8 * Up to
(including)
8u292-b10-3
运行在以下环境
系统 fedora_33 openjdk-8 * Up to
(excluding)
11.0.12.0.7-0.fc33
运行在以下环境
系统 fedora_34 openjdk-8 * Up to
(excluding)
11.0.12.0.7-0.fc34
运行在以下环境
系统 fedora_EPEL_8 glances * Up to
(excluding)
3.2.5-1.el8
运行在以下环境
系统 opensuse_Leap_15.2 openjdk-8 * Up to
(excluding)
1.8.0.312-lp152.3.12.1
运行在以下环境
系统 opensuse_Leap_15.3 openjdk-8 * Up to
(excluding)
1.8.0.312-3.18.2
运行在以下环境
系统 oracle_7 openjdk-8 * Up to
(excluding)
11.0.12.0.7-0.0.1.el7_9
运行在以下环境
系统 oracle_8 openjdk-8 * Up to
(excluding)
1.8.0.302.b08-0.el8_4
运行在以下环境
系统 redhat_7 java-1.8.0-openjdk * Up to
(excluding)
1:1.8.0.302.b08-0.el7_9
运行在以下环境
系统 redhat_8 openjdk-8 * Up to
(excluding)
1.8.0.6.35-1.el8_4
运行在以下环境
系统 suse_12_SP5 openjdk-8 * Up to
(excluding)
11.0.12.0-3.27.2
运行在以下环境
系统 ubuntu_16.04 openjdk-8 * Up to
(excluding)
8u312-b07-0ubuntu1~16.04
运行在以下环境
系统 ubuntu_18.04 openjdk-8 * Up to
(excluding)
8u312-b07-0ubuntu1~18.04
运行在以下环境
系统 ubuntu_20.04 openjdk-8 * Up to
(excluding)
8u312-b07-0ubuntu1~20.04
运行在以下环境
系统 ubuntu_21.04 openjdk-8 * Up to
(excluding)
8u312-b07-0ubuntu1~21.04
运行在以下环境
系统 ubuntu_21.10 openjdk-8 * Up to
(excluding)
11.0.12+7-0ubuntu1
运行在以下环境
系统 ubuntu_22.04 openjdk-8 * Up to
(excluding)
11.0.12+7-0ubuntu1
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况