低危 openssl openssl 整数溢出或超界折返

CVE编号

CVE-2021-23840

利用情况

暂无

补丁情况

没有补丁

披露时间

2021-02-17 06:15:00
漏洞描述
OpenSSL是用于传输层安全性(TLS)和安全套接字层(SSL)协议的功能强大的,商业级且功能齐全的工具包。它也是一个通用密码库。OpenSSL存在输入验证错误漏洞,攻击者可利用该漏洞导致应用程序行为错误或崩溃。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://www.openssl.org/news/secadv/20210216.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl * From
(including)
1.0.2
Up to
(excluding)
1.0.2y
运行在以下环境
应用 openssl openssl * From
(including)
1.1.1
Up to
(excluding)
1.1.1j
2
运行在以下环境
系统 ubuntu_16.04.7_lts openssl * Up to
(excluding)
1.0.2g-1ubuntu4.19
运行在以下环境
系统 ubuntu_18.04.5_lts openssl * Up to
(excluding)
1.1.1-1ubuntu2.1~18.04.8
3
运行在以下环境
系统 debian_11 openssl * Up to
(excluding)
1.1.1i-3
4
运行在以下环境
系统 alpine_3.14 openssl * Up to
(excluding)
1.1.1j-r0
5
运行在以下环境
系统 debian_10 openssl * Up to
(excluding)
1.1.1d-0+deb10u7
6
运行在以下环境
系统 alpine_3.13 openssl * Up to
(excluding)
1.1.1j-r0
7
运行在以下环境
系统 alpine_3.11 openssl * Up to
(excluding)
1.1.1j-r0
8
运行在以下环境
系统 ubuntu_21.04 openssl * Up to
(excluding)
1.1.1j-1ubuntu1
9
运行在以下环境
系统 ubuntu_16.04 openssl * Up to
(excluding)
1.0.2g-1ubuntu4.19
10
运行在以下环境
系统 ubuntu_20.04 openssl * Up to
(excluding)
1.1.1f-1ubuntu2.2
11
运行在以下环境
系统 alpine_3.9 openssl * Up to
(excluding)
1.1.1j-r0
12
运行在以下环境
系统 amazon_AMI openssl * Up to
(excluding)
1.0.2k-16.153.amzn1
13
运行在以下环境
系统 alpine_3.10 openssl * Up to
(excluding)
1.1.1j-r0
14
运行在以下环境
系统 alpine_3.12 openssl * Up to
(excluding)
1.1.1j-r0
15
运行在以下环境
系统 amazon_2 openssl * Up to
(excluding)
1.0.2k-19.amzn2.0.6
16
运行在以下环境
系统 debian_9 openssl * Up to
(excluding)
1.1.0f-3+deb9u2
17
运行在以下环境
系统 ubuntu_18.04 openssl * Up to
(excluding)
1.0.2n-1ubuntu5.6
18
运行在以下环境
系统 alpine_edge openssl * Up to
(excluding)
1.1.1j-r0
19
运行在以下环境
系统 opensuse_Leap_15.2 openssl * Up to
(excluding)
12.21.0-lp152.3.12.1
20
运行在以下环境
系统 opensuse_Leap_15.2 openssl * Up to
(excluding)
10.24.0-lp152.2.12.1
21
运行在以下环境
系统 suse_12_SP5 openssl * Up to
(excluding)
1.1.1d-2.30.1
22
运行在以下环境
系统 alibaba_cloud_linux_2.1903 openssl * Up to
(excluding)
1.0.2k-22.1.al7
23
运行在以下环境
系统 suse_12_SP5 openssl * Up to
(excluding)
1.0.2p-3.36.1
24
运行在以下环境
系统 opensuse_Leap_15.2 openssl * Up to
(excluding)
1.1.1d-lp152.7.12.1
25
运行在以下环境
系统 opensuse_Leap_15.2 openssl * Up to
(excluding)
1.0.2p-lp152.8.12.1
阿里云评分
3.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况