高危 parlai 安全漏洞

CVE编号

CVE-2021-24040

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2021-09-13
漏洞描述
parlai是用于在各种公开可用的对话数据集上训练和评估 AI 模型。
ParlAI v1.1.0之前版本存在安全漏洞,该漏洞源于不安全的YAML反序列化逻辑。攻击者可利用该漏洞修改本地YAML配置文件,可能导致远程代码执行或类似风险。
受影响系统:
parlai parlai < 1.1.0
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/facebookresearch/ParlAI/security/advisories/GHSA-m87f-9fvv-2mgg
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 facebook parlai * Up to
(excluding)
1.1.0
阿里云评分
7.0
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况