低危 Apache Tomcat信息泄露漏洞

CVE编号

CVE-2021-24122

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-01-15
漏洞描述
Apache Tomcat是美国阿帕奇(Apache)基金会的一款轻量级Web应用服务器。该程序实现了对Servlet和JavaServer Page(JSP)的支持。

Apache Tomcat 存在安全漏洞,该漏洞源于JRE API File.getCanonicalPath() 与 Windows API (FindFirstFileW)行为不一致。攻击者可能利用此漏洞泄露网站JSP源码。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:https://lists.apache.org/thread.html/r776c64337495bf28b7d5597268114a888e3fad6045c40a0da0c66d4d@%3Cdev.tomee.apache.org%3E
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
7.0.0
Up to
(including)
7.0.106
运行在以下环境
应用 apache tomcat * From
(including)
8.5.0
Up to
(including)
8.5.59
运行在以下环境
应用 apache tomcat * From
(including)
9.0.1
Up to
(including)
9.0.39
运行在以下环境
应用 apache tomcat 10.0.0 -
运行在以下环境
应用 apache tomcat 9.0.0 -
运行在以下环境
系统 debian_10 tomcat9 * Up to
(including)
9.0.31-1~deb10u6
运行在以下环境
系统 debian_9 tomcat9 * Up to
(including)
7.0.75-1
运行在以下环境
系统 opensuse_Leap_15.2 tomcat9 * Up to
(excluding)
9.0.36-lp152.2.19.1
运行在以下环境
系统 suse_12_SP5 tomcat9 * Up to
(excluding)
9.0.36-3.61.1
阿里云评分
3.3
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况