低危 debian debian_linux reachable assertion

CVE编号

CVE-2021-25216

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-04-29
漏洞描述
In BIND 9.5.0 -> 9.11.29, 9.12.0 -> 9.16.13, and versions BIND 9.11.3-S1 -> 9.11.29-S1 and 9.16.8-S1 -> 9.16.13-S1 of BIND Supported Preview Edition, as well as release versions 9.17.0 -> 9.17.1 of the BIND 9.17 development branch, BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting values for the tkey-gssapi-keytab or tkey-gssapi-credential configuration options. Although the default configuration is not vulnerable, GSS-TSIG is frequently used in networks where BIND is integrated with Samba, as well as in mixed-server environments that combine BIND servers with Active Directory domain controllers. For servers that meet these conditions, the ISC SPNEGO implementation is vulnerable to various attacks, depending on the CPU architecture for which BIND was built: For named binaries compiled for 64-bit platforms, this flaw can be used to trigger a buffer over-read, leading to a server crash. For named binaries compiled for 32-bit platforms, this flaw can be used to trigger a server crash due to a buffer overflow and possibly also to achieve remote code execution. We have determined that standard SPNEGO implementations are available in the MIT and Heimdal Kerberos libraries, which support a broad range of operating systems, rendering the ISC implementation unnecessary and obsolete. Therefore, to reduce the attack surface for BIND users, we will be removing the ISC SPNEGO implementation in the April releases of BIND 9.11 and 9.16 (it had already been dropped from BIND 9.17). We would not normally remove something from a stable ESV (Extended Support Version) of BIND, but since system libraries can replace the ISC SPNEGO implementation, we have made an exception in this case for reasons of stability and security.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 isc bind * From
(including)
9.0.0
Up to
(excluding)
9.11.31
运行在以下环境
应用 isc bind * From
(including)
9.12.0
Up to
(excluding)
9.16.15
运行在以下环境
应用 isc bind * From
(including)
9.17.0
Up to
(excluding)
9.17.12
运行在以下环境
应用 isc bind 9.10.5 -
运行在以下环境
应用 isc bind 9.10.7 -
运行在以下环境
应用 isc bind 9.11.12 -
运行在以下环境
应用 isc bind 9.11.21 -
运行在以下环境
应用 isc bind 9.11.27 -
运行在以下环境
应用 isc bind 9.11.29 -
运行在以下环境
应用 isc bind 9.11.3 -
运行在以下环境
应用 isc bind 9.11.5 -
运行在以下环境
应用 isc bind 9.11.6 -
运行在以下环境
应用 isc bind 9.11.7 -
运行在以下环境
应用 isc bind 9.11.8 -
运行在以下环境
应用 isc bind 9.16.11 -
运行在以下环境
应用 isc bind 9.16.13 -
运行在以下环境
应用 isc bind 9.16.8 -
运行在以下环境
应用 isc bind 9.9.12 -
运行在以下环境
应用 isc bind 9.9.13 -
运行在以下环境
应用 isc bind 9.9.3 -
运行在以下环境
系统 alpine_3.10 bind * Up to
(excluding)
9.16.15-r0
运行在以下环境
系统 alpine_3.11 bind * Up to
(excluding)
9.16.15-r0
运行在以下环境
系统 alpine_3.12 bind * Up to
(excluding)
9.16.15-r0
运行在以下环境
系统 alpine_3.13 bind * Up to
(excluding)
9.16.15-r0
运行在以下环境
系统 alpine_3.14 bind * Up to
(excluding)
9.16.15-r0
运行在以下环境
系统 alpine_3.15 bind * Up to
(excluding)
9.16.15-r0
运行在以下环境
系统 alpine_edge bind * Up to
(excluding)
9.16.15-r0
运行在以下环境
系统 debian debian_linux 10.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 bind * Up to
(excluding)
1:9.11.5.P4+dfsg-5.1+deb10u5
运行在以下环境
系统 debian_11 bind * Up to
(excluding)
9.16.13-1
运行在以下环境
系统 debian_9 bind * Up to
(excluding)
1:9.10.3.dfsg.P4-12.3+deb9u9
运行在以下环境
系统 ubuntu_16.04 bind * Up to
(excluding)
1:9.10.3.dfsg.P4-8ubuntu1.19
运行在以下环境
系统 ubuntu_18.04 bind * Up to
(excluding)
1:9.11.3+dfsg-1ubuntu1.15
运行在以下环境
系统 ubuntu_18.04.5_lts bind9 * Up to
(excluding)
1:9.11.3+dfsg-1ubuntu1.15
运行在以下环境
系统 ubuntu_20.04 bind * Up to
(excluding)
1:9.16.1-0ubuntu2.8
运行在以下环境
系统 ubuntu_21.04 bind * Up to
(excluding)
1:9.16.8-1ubuntu3.1
阿里云评分
3.8
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    N/A
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-617 可达断言
阿里云安全产品覆盖情况