中危 Bind named 处理逻辑错误漏洞

CVE编号

CVE-2021-25218

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-08-18
漏洞描述
ISC BIND是美国ISC公司的一套实现了DNS协议的开源软件。
Bind named 存在处理逻辑错误漏洞,该漏洞源于 named 尝试使用大于当前有效接口最大传输单元 (MTU) 的响应通过 UDP 进行响应,并且如果响应速率限制 (RRL) 处于活动状态,则会触发断言失败(导致 named 服务器进程终止)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://kb.isc.org/v1/docs/cve-2021-25218
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 isc bind 9.16.19 -
运行在以下环境
应用 isc bind 9.17.16 -
运行在以下环境
系统 alpine_3.11 bind * Up to
(excluding)
9.16.20-r0
运行在以下环境
系统 alpine_3.12 bind * Up to
(excluding)
9.16.20-r0
运行在以下环境
系统 alpine_3.13 bind * Up to
(excluding)
9.16.20-r0
运行在以下环境
系统 alpine_3.14 bind * Up to
(excluding)
9.16.20-r0
运行在以下环境
系统 alpine_3.15 bind * Up to
(excluding)
9.16.20-r0
运行在以下环境
系统 alpine_edge bind * Up to
(excluding)
9.16.20-r0
运行在以下环境
系统 fedora_34 bind * Up to
(excluding)
9.16.20-2.fc34
阿里云评分
6.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-617 可达断言
阿里云安全产品覆盖情况