中危 Apache Tomcat Session 反序列化代码执行漏洞

CVE编号

CVE-2021-25329

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-03-02
漏洞描述
Apache Tomcat是由Apache软件基金会属下Jakarta项目开发的Servlet容器。在CVE-2021-25329 Apache Tomcat Session 反序列化代码执行漏洞中,由于官方在CVE-2020-9484漏洞修复上存在不足,攻击者可能可以构造恶意请求,绕过CVE-2020-9484补丁,造成反序列化代码执行漏洞。成功利用该漏洞需要同时满足下列四个条件:

1. 攻击者能够控制服务器上文件的内容和名称

2. 服务器PersistenceManager配置中使用了FileStore

3. 服务器PersistenceManager配置中设置了sessionAttributeValueClassNameFilter为NULL,或者使用了其他较为宽松的过滤器,允许攻击者提供反序列化数据对象

4. 攻击者知道使用的FileStore存储位置到可控文件的相对文件路径。
解决建议
1、升级Apache Tomcat至安全版本

2、禁止使用Session持久化功能FileStore
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
7.0.0
Up to
(including)
7.0.107
运行在以下环境
应用 apache tomcat * From
(including)
8.5.0
Up to
(including)
8.5.61
运行在以下环境
应用 apache tomcat * From
(including)
9.0.0
Up to
(including)
9.0.41
运行在以下环境
应用 apache tomcat 10.0.0 -
运行在以下环境
应用 apache tomcat 9.0.0 -
运行在以下环境
系统 amazon linux_AMI tomcat7 * Up to
(excluding)
3.0-api-7.0.108-1.40.amzn1
运行在以下环境
系统 amazon_AMI tomcat7 * Up to
(excluding)
7.0.108-1.40.amzn1
运行在以下环境
系统 debian_10 tomcat7 * Up to
(excluding)
9.0.31-1~deb10u4
运行在以下环境
系统 debian_9 tomcat7 * Up to
(including)
7.0.75-1
运行在以下环境
系统 opensuse_Leap_15.2 tomcat7 * Up to
(excluding)
9.0.36-lp152.2.22.1
运行在以下环境
系统 sles_12_SP5 tomcat7 * Up to
(excluding)
9.0.36-3.64.1
运行在以下环境
系统 suse_12_SP5 tomcat7 * Up to
(excluding)
9.0.36-3.64.1
运行在以下环境
系统 ubuntu_18.04 tomcat9 * Up to
(excluding)
9.0.16-3ubuntu0.18.04.2
运行在以下环境
系统 ubuntu_20.04 tomcat9 * Up to
(excluding)
9.0.31-1ubuntu0.2
阿里云评分
5.9
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况