LibreOffice up to 7.0.4/7.1.1 Denylist ShellExecute incomplete blacklist

CVE编号

CVE-2021-25631

利用情况

暂无

补丁情况

N/A

披露时间

2021-05-03
漏洞描述
In the LibreOffice 7-1 series in versions prior to 7.1.2, and in the 7-0 series in versions prior to 7.0.5, the denylist can be circumvented by manipulating the link so it doesn't match the denylist but results in ShellExecute attempting to launch an executable type.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libreoffice libreoffice * From
(including)
7.0.0
Up to
(excluding)
7.0.5
运行在以下环境
应用 libreoffice libreoffice * From
(including)
7.1.0
Up to
(excluding)
7.1.2
CVSS3评分
8.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况