高危 Apache Hadoop Yarn ZKConfigurationStore 反序列化代码执行漏洞(CVE-2021-25642)

CVE编号

CVE-2021-25642

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-08-25
漏洞描述
2022年8月25日,Apache Hadoop官方披露CVE-2021-25642 Apache Hadoop Yarn 反序列化代码执行漏洞。Apache Hadoop YARN CapacityScheduler 在使用 ZKConfigurationStore时,会从ZooKeeper中获取的数据并进行反序列化。能够访问ZooKeeper的攻击者可以利用该漏洞以YARN用户的身份运行任意命令。

漏洞利用条件需要额外配置,且要求攻击者能控制ZooKeeper中的数据,实际利用条件复杂苛刻。实际风险低

影响版本
2.9.0 <= Apache Hadoo <= 2.10.1
3.0.0-alpha <= Apache Hadoo <= 3.2.3
3.3.0 <= Apache Hadoo <= 3.3.3

安全版本
Apache Hadoop 2.10.2
Apache Hadoop 3.2.4
Apache Hadoop 3.3.4
解决建议
官方已发布相关安全更新,若您使用了 ZKConfigurationStore,建议升级至最新版本。

受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache hadoop * From
(including)
2.9.0
Up to
(excluding)
2.10.2
运行在以下环境
应用 apache hadoop * From
(including)
3.0.0
Up to
(excluding)
3.2.4
运行在以下环境
应用 apache hadoop * From
(including)
3.3.0
Up to
(excluding)
3.3.4
阿里云评分
7.0
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况