中危 digium asterisk 不恰当的资源关闭或释放

CVE编号

CVE-2021-26906

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-02-19
漏洞描述
An issue was discovered in res_pjsip_session.c in Digium Asterisk through 13.38.1; 14.x, 15.x, and 16.x through 16.16.0; 17.x through 17.9.1; and 18.x through 18.2.0, and Certified Asterisk through 16.8-cert5. An SDP negotiation vulnerability in PJSIP allows a remote server to potentially crash Asterisk by sending specific SIP responses that cause an SDP negotiation failure.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 digium asterisk * From
(including)
13.0.0
Up to
(excluding)
13.38.2
运行在以下环境
应用 digium asterisk * From
(including)
16.0.0
Up to
(excluding)
16.16.1
运行在以下环境
应用 digium asterisk * From
(including)
17.0.0
Up to
(excluding)
17.9.2
运行在以下环境
应用 digium asterisk * From
(including)
18.0
Up to
(excluding)
18.2.1
运行在以下环境
应用 digium certified_asterisk 16.8 -
运行在以下环境
系统 alpine_3.12 asterisk * Up to
(excluding)
16.16.1-r0
运行在以下环境
系统 alpine_3.13 asterisk * Up to
(excluding)
18.2.1-r0
运行在以下环境
系统 alpine_3.14 asterisk * Up to
(excluding)
18.2.1-r0
运行在以下环境
系统 alpine_3.15 asterisk * Up to
(excluding)
18.2.1-r0
运行在以下环境
系统 alpine_3.16 asterisk * Up to
(excluding)
18.2.1-r0
运行在以下环境
系统 alpine_3.17 asterisk * Up to
(excluding)
18.2.1-r0
运行在以下环境
系统 alpine_edge asterisk * Up to
(excluding)
18.2.1-r0
运行在以下环境
系统 debian_10 asterisk * Up to
(including)
16.2.1~dfsg-1+deb10u2
运行在以下环境
系统 debian_11 asterisk * Up to
(including)
16.15.1~dfsg-1
运行在以下环境
系统 debian_9 asterisk * Up to
(including)
13.14.1~dfsg-2+deb9u4
阿里云评分
4.1
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-404 不恰当的资源关闭或释放
阿里云安全产品覆盖情况