中危 Puppet Agent和Puppet Server HTTP重定向漏洞

CVE编号

CVE-2021-27023

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-11-22
漏洞描述
Puppet Agent是一个Puppet代理端程序。Puppet Server是一款用于将配置从主服务器推送到其他服务器的软件。
Puppet Agent 和Puppet Server存在HTTP重定向漏洞。攻击者可利用该漏洞在执行HTTP重定向至其他主机时导致HTTP凭据泄露。

受影响系统:
Puppet Server < 7.4.2
Puppet Server < 6.17.1
Puppet Agent < 7.12.1
Puppet Agent < 6.25.1
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://puppet.com/security/cve/cve-2021-27023
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * Up to
(excluding)
2019.8.9
运行在以下环境
应用 puppet puppet * From
(including)
2021.0.0
Up to
(excluding)
2021.4
运行在以下环境
应用 puppet puppet_agent * Up to
(excluding)
6.25.1
运行在以下环境
应用 puppet puppet_agent * From
(including)
7.0.0
Up to
(excluding)
7.12.1
运行在以下环境
应用 puppet puppet_server * Up to
(excluding)
6.17.1
运行在以下环境
应用 puppet puppet_server * From
(including)
7.0.0
Up to
(excluding)
7.4.2
运行在以下环境
系统 centos_8 puppet * Up to
(excluding)
6.26.0-1.el8sat
运行在以下环境
系统 debian_10 puppet * Up to
(including)
5.5.10-4
运行在以下环境
系统 debian_11 puppet * Up to
(including)
5.5.22-2
运行在以下环境
系统 debian_12 puppet * Up to
(including)
5.5.22-4
运行在以下环境
系统 debian_9 puppet * Up to
(including)
4.8.2-5
运行在以下环境
系统 debian_sid puppet * Up to
(including)
5.5.22-4
运行在以下环境
系统 fedora_35 puppet * Up to
(excluding)
7.12.1-1.fc35
运行在以下环境
系统 fedora_EPEL_8 puppet * Up to
(excluding)
6.25.1-1.el8
运行在以下环境
系统 redhat_8 puppet * Up to
(excluding)
6.26.0-1.el8sat
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况