低危 openldap openldap 可达断言

CVE编号

CVE-2021-27212

利用情况

暂无

补丁情况

没有补丁

披露时间

2021-02-14
漏洞描述
In OpenLDAP through 2.4.57 and 2.5.x through 2.5.1alpha, an assertion failure in slapd can occur in the issuerAndThisUpdateCheck function via a crafted packet, resulting in a denial of service (daemon exit) via a short timestamp. This is related to schema_init.c and checkTime.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openldap openldap * Up to
(including)
2.4.57
运行在以下环境
应用 openldap openldap 2.5.0 -
运行在以下环境
应用 openldap openldap 2.5.1 -
运行在以下环境
系统 alpine_3.12 openldap * Up to
(excluding)
2.4.50-r2
运行在以下环境
系统 alpine_3.13 openldap * Up to
(excluding)
2.4.57-r1
运行在以下环境
系统 alpine_3.14 openldap * Up to
(excluding)
2.4.57-r1
运行在以下环境
系统 alpine_3.15 openldap * Up to
(excluding)
2.4.57-r1
运行在以下环境
系统 alpine_3.16 openldap * Up to
(excluding)
2.4.57-r1
运行在以下环境
系统 alpine_3.17 openldap * Up to
(excluding)
2.4.57-r1
运行在以下环境
系统 alpine_3.18 openldap * Up to
(excluding)
2.4.57-r1
运行在以下环境
系统 alpine_3.19 openldap * Up to
(excluding)
2.4.57-r1
运行在以下环境
系统 amazon_2 openldap * Up to
(excluding)
2.4.44-25.amzn2.0.5
运行在以下环境
系统 amazon_2023 openldap * Up to
(excluding)
2.4.57-6.amzn2023.0.4
运行在以下环境
系统 amazon_AMI openldap * Up to
(excluding)
2.4.40-16.36.amzn1
运行在以下环境
系统 debian_10 openldap * Up to
(excluding)
2.4.47+dfsg-3+deb10u6
运行在以下环境
系统 debian_11 openldap * Up to
(excluding)
2.4.57+dfsg-2
运行在以下环境
系统 debian_12 openldap * Up to
(excluding)
2.4.57+dfsg-2
运行在以下环境
系统 debian_9 openldap * Up to
(excluding)
2.4.44+dfsg-5+deb9u8
运行在以下环境
系统 kylinos_aarch64_V10 openldap * Up to
(excluding)
2.4.50-6.p03.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP1 openldap * Up to
(excluding)
2.4.50-7.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP3 openldap * Up to
(excluding)
2.4.50-6.p03.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP1 openldap * Up to
(excluding)
2.4.50-7.a.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP3 openldap * Up to
(excluding)
2.4.50-7.p01.a.ky10
运行在以下环境
系统 kylinos_x86_64_V10 openldap * Up to
(excluding)
2.4.50-6.p03.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP1 openldap * Up to
(excluding)
2.4.50-7.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP2 openldap * Up to
(excluding)
2.4.50-7.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP3 openldap * Up to
(excluding)
2.4.50-6.p03.ky10
运行在以下环境
系统 opensuse_Leap_15.2 openldap2 * Up to
(excluding)
1.2-lp152.14.18.1
运行在以下环境
系统 suse_12_SP5 openldap2 * Up to
(excluding)
2.4.41-18.83.1
运行在以下环境
系统 ubuntu_16.04 openldap * Up to
(excluding)
2.4.42+dfsg-2ubuntu3.13
运行在以下环境
系统 ubuntu_18.04 openldap * Up to
(excluding)
2.4.45+dfsg-1ubuntu1.10
运行在以下环境
系统 ubuntu_20.04 openldap * Up to
(excluding)
2.4.49+dfsg-2ubuntu1.7
运行在以下环境
系统 ubuntu_21.04 openldap * Up to
(excluding)
2.4.57+dfsg-2ubuntu1
运行在以下环境
系统 ubuntu_21.10 openldap * Up to
(excluding)
2.4.57+dfsg-2ubuntu1
运行在以下环境
系统 ubuntu_22.04 openldap * Up to
(excluding)
2.4.57+dfsg-2ubuntu1
运行在以下环境
系统 ubuntu_22.10 openldap * Up to
(excluding)
2.4.57+dfsg-2ubuntu1
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    没有补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-617 可达断言
阿里云安全产品覆盖情况