低危 Go拒绝服务漏洞(CNVD-2021-19693)

CVE编号

CVE-2021-27919

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-03-11
漏洞描述
Google Go是美国谷歌(Google)公司的一款静态强类型、编译型、并发型,并具有垃圾回收功能的编程语言。

Go中的archive/zip在尝试对文件名以../开头的ZIP存档文件使用Reader.Open API时存在拒绝服务漏洞。攻击者可利用该漏洞导致拒绝服务。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://groups.google.com/g/golang-announce/c/MfiLYjG-RAw
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * From
(including)
1.16.0
Up to
(excluding)
1.16.1
运行在以下环境
系统 alpine_3.13 go * Up to
(excluding)
1.15.10-r0
运行在以下环境
系统 alpine_3.14 go * Up to
(excluding)
1.16.2-r0
运行在以下环境
系统 alpine_3.15 go * Up to
(excluding)
1.16.2-r0
运行在以下环境
系统 alpine_3.16 go * Up to
(excluding)
1.16.2-r0
运行在以下环境
系统 alpine_edge go * Up to
(excluding)
1.16.2-r0
运行在以下环境
系统 fedora_34 go * Up to
(excluding)
1.16.8-1.fc34
运行在以下环境
系统 fedora_35 go * Up to
(excluding)
1.16.8-2.fc35
阿里云评分
3.3
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况