低危 Alpine Linux apk-tools 缓冲区溢出漏洞

CVE编号

CVE-2021-30139

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-04-22
漏洞描述
In Alpine Linux apk-tools before 2.12.5, the tarball parser allows a buffer overflow and crash.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alpinelinux apk-tools * Up to
(excluding)
2.10.6
运行在以下环境
系统 alpinelinux apk-tools * From
(including)
2.12.0
Up to
(excluding)
2.12.5
运行在以下环境
系统 alpine_3.10 apk-tools * Up to
(excluding)
2.10.6-r0
运行在以下环境
系统 alpine_3.11 apk-tools * Up to
(excluding)
2.10.6-r0
运行在以下环境
系统 alpine_3.12 apk-tools * Up to
(excluding)
2.10.6-r0
运行在以下环境
系统 alpine_3.13 apk-tools * Up to
(excluding)
2.12.5-r0
运行在以下环境
系统 alpine_3.14 apk-tools * Up to
(excluding)
2.12.5-r0
运行在以下环境
系统 alpine_3.15 apk-tools * Up to
(excluding)
2.12.5-r0
运行在以下环境
系统 alpine_3.16 apk-tools * Up to
(excluding)
2.12.5-r0
运行在以下环境
系统 alpine_edge apk-tools * Up to
(excluding)
2.12.5-r0
阿里云评分
2.8
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况