中危 Apache Tomcat 授权问题漏洞(CVE-2021-30640)

CVE编号

CVE-2021-30640

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-12
漏洞描述
Apache Tomcat是美国阿帕奇(Apache)基金会的一款轻量级Web应用服务器。该程序实现了对Servlet和JavaServer Page(JSP)的支持。

Apache Tomcat存在授权问题漏洞,该漏洞源于Apache Tomcat 的 JNDI 领域中的一个漏洞允许攻击者使用有效用户名的变体进行身份验证和/或绕过锁定领域提供的某些保护。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://lists.apache.org/thread.html/r59f9ef03929d32120f91f4ea7e6e79edd5688d75d0a9b65fd26d1fe8%40%3Cannounce.tomcat.apache.org%3E
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
10.0.0
Up to
(excluding)
10.0.6
运行在以下环境
应用 apache tomcat * From
(including)
7.0.0
Up to
(excluding)
7.0.109
运行在以下环境
应用 apache tomcat * From
(including)
8.5.0
Up to
(excluding)
8.5.66
运行在以下环境
应用 apache tomcat * From
(including)
9.0.0
Up to
(excluding)
9.0.46
运行在以下环境
应用 oracle communications_diameter_signaling_router * From
(including)
8.0.0
Up to
(including)
8.5.0
运行在以下环境
系统 amazon_AMI tomcat7 * Up to
(excluding)
7.0.109-1.41.amzn1
运行在以下环境
系统 debian_10 tomcat7 * Up to
(excluding)
9.0.31-1~deb10u6
运行在以下环境
系统 debian_11 tomcat7 * Up to
(excluding)
9.0.43-2~deb11u1
运行在以下环境
系统 debian_9 tomcat7 * Up to
(excluding)
8.5.54-0+deb9u7
运行在以下环境
系统 debian_sid tomcat7 * Up to
(including)
9.0.43-1
运行在以下环境
系统 opensuse_Leap_15.2 tomcat7 * Up to
(excluding)
9.0.36-lp152.2.25.1
运行在以下环境
系统 opensuse_Leap_15.3 tomcat7 * Up to
(excluding)
9.0.36-13.1
运行在以下环境
系统 suse_12_SP5 tomcat7 * Up to
(excluding)
9.0.36-3.71.1
运行在以下环境
系统 ubuntu_18.04 tomcat9 * Up to
(excluding)
9.0.16-3ubuntu0.18.04.2
运行在以下环境
系统 ubuntu_20.04 tomcat9 * Up to
(excluding)
9.0.31-1ubuntu0.2
阿里云评分
5.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况