低危 freedesktop gst-plugins-bad 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)

CVE编号

CVE-2021-3185

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-01-27
漏洞描述
A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could cause the stack to be smashed, memory corruption and possibly code execution.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop gst-plugins-bad * Up to
(excluding)
1.18.1
运行在以下环境
系统 debian_10 gst-plugins-bad1.0 * Up to
(excluding)
1.14.4-1deb10u1
运行在以下环境
系统 debian_9 gst-plugins-bad1.0 * Up to
(excluding)
1.10.4-1+deb9u1
运行在以下环境
系统 opensuse_Leap_15.2 gst-plugins-bad1.0 * Up to
(excluding)
0-1.16.3-lp152.3.3.1
运行在以下环境
系统 opensuse_Leap_15.3 gst-plugins-bad1.0 * Up to
(excluding)
0-1.16.3-4.3.1
运行在以下环境
系统 suse_12_SP5 gst-plugins-bad1.0 * Up to
(excluding)
0-1.8.3-18.3.5
阿里云评分
3.5
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-120 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)
CWE-121 栈缓冲区溢出
CWE-787 跨界内存写
阿里云安全产品覆盖情况